aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-06-23 14:46:13 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-06-23 14:46:13 +0800
commitb106b13525048195d99bcbde31e0e535972cbab4 (patch)
tree87b999777762c5bcea16a9430fbb94cc560de8c0 /shell/Makefile.am
parent72ca61d74b9942040638b628a6f1358e02d23d42 (diff)
downloadgsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar.gz
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar.bz2
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar.lz
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar.xz
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.tar.zst
gsoc2013-evolution-b106b13525048195d99bcbde31e0e535972cbab4.zip
Implemented an Evolution::Activity interface for keeping track of
background tasks. The Activity interface is added to the shell, and the status of the various tasks is now displayed in a task bar widget at the bottom of the EShellView. I also implemented a simple test component to test all this stuff. svn path=/trunk/; revision=10434
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am58
1 files changed, 47 insertions, 11 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 2dcbcb2496..08c24b5268 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,6 +1,6 @@
SUBDIRS = glade importer
-INCLUDES = \
+INCLUDES = -O \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/widgets/misc \
-I$(top_srcdir) \
@@ -16,15 +16,17 @@ INCLUDES = \
# CORBA stuff
IDLS = \
- Evolution-LocalStorage.idl \
- Evolution-Offline.idl \
- Evolution-Session.idl \
- Evolution-Shell.idl \
- Evolution-ShellComponent.idl \
- Evolution-ShellComponentDnd.idl \
- Evolution-ShellView.idl \
- Evolution-Storage.idl \
- Evolution-StorageSetView.idl \
+ Evolution-Activity.idl \
+ Evolution-Icon.idl \
+ Evolution-LocalStorage.idl \
+ Evolution-Offline.idl \
+ Evolution-Session.idl \
+ Evolution-Shell.idl \
+ Evolution-ShellComponent.idl \
+ Evolution-ShellComponentDnd.idl \
+ Evolution-ShellView.idl \
+ Evolution-Storage.idl \
+ Evolution-StorageSetView.idl \
Evolution.idl
IDL_GENERATED = \
@@ -88,6 +90,8 @@ libeshell_la_SOURCES = \
bin_PROGRAMS = evolution
evolution_SOURCES = \
+ e-activity-handler.c \
+ e-activity-handler.h \
e-component-registry.c \
e-component-registry.h \
e-corba-storage-registry.c \
@@ -139,6 +143,10 @@ evolution_SOURCES = \
e-storage-set.h \
e-storage.c \
e-storage.h \
+ e-task-bar.c \
+ e-task-bar.h \
+ e-task-widget.c \
+ e-task-widget.h \
evolution-storage-set-view.c \
evolution-storage-set-view.h \
evolution-storage-set-view-factory.c \
@@ -155,6 +163,29 @@ evolution_LDADD = \
$(GTKHTML_LIBS) \
$(BONOBO_GNOME_LIBS)
+# Test component
+
+noinst_PROGRAMS = \
+ evolution-test-component
+
+evolution_test_component_SOURCES = \
+ evolution-test-component.c
+
+evolution_test_component_LDADD = \
+ libeshell.la \
+ $(EXTRA_GNOME_LIBS) \
+ $(GNOME_PRINT_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(BONOBO_GNOME_LIBS)
+
+install-test-component: evolution-test-component
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution-test-component $(DESTDIR)$(bindir)/evolution-test-component
+ $(mkinstalldirs) $(DESTDIR)$(oafdir)
+ $(INSTALL_DATA) $(srcdir)/GNOME_Evolution_TestComponent.oafinfo $(DESTDIR)$(oafdir)/GNOME_Evolution_TestComponent.oafinfo
+
+# Misc stuff
+
oafdir = $(datadir)/oaf
oaf_in_files = GNOME_Evolution_Shell.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
@@ -164,7 +195,12 @@ etspec_DATA = e-storage-set-view.etspec
@XML_I18N_MERGE_OAF_RULE@
-EXTRA_DIST = $(IDLS) $(oaf_in_files) $(oaf_DATA) $(etspec_DATA)
+EXTRA_DIST = \
+ $(IDLS) \
+ $(oaf_in_files) \
+ $(oaf_DATA) \
+ $(etspec_DATA) \
+ GNOME_Evolution_TestComponent.oafinfo
# Purify support