aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tnef-attachments/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2009-01-29 01:35:12 +0800
committerTor Lillqvist <tml@src.gnome.org>2009-01-29 01:35:12 +0800
commit6ae40bce3032f0ca141640cfa14b7d6e4d015948 (patch)
tree391da4845e0c1b2407e6a05ec3bdab3b748e282d /plugins/tnef-attachments/Makefile.am
parent24ab144be229febc05b51817b343e3841f41bf7f (diff)
downloadgsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar.gz
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar.bz2
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar.lz
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar.xz
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.tar.zst
gsoc2013-evolution-6ae40bce3032f0ca141640cfa14b7d6e4d015948.zip
Use -no-undefined and link with more libraries on Windows.
2009-01-28 Tor Lillqvist <tml@novell.com> * Makefile.am: Use -no-undefined and link with more libraries on Windows. * tnef-plugin.c: Remove unused <sys/wait.h>. svn path=/trunk/; revision=37153
Diffstat (limited to 'plugins/tnef-attachments/Makefile.am')
-rw-r--r--plugins/tnef-attachments/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/plugins/tnef-attachments/Makefile.am b/plugins/tnef-attachments/Makefile.am
index 7f52413306..809d1ed1f4 100644
--- a/plugins/tnef-attachments/Makefile.am
+++ b/plugins/tnef-attachments/Makefile.am
@@ -1,3 +1,11 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la
+endif
+
INCLUDES = \
-I$(top_srcdir) \
-DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
@@ -11,7 +19,10 @@ plugin_DATA = org-gnome-tnef-attachments.eplug
plugin_LTLIBRARIES = liborg-gnome-tnef-attachments.la
liborg_gnome_tnef_attachments_la_SOURCES = tnef-plugin.c
-liborg_gnome_tnef_attachments_la_LDFLAGS = -module -avoid-version -lytnef
+liborg_gnome_tnef_attachments_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_tnef_attachments_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS) \
+ -lytnef
EXTRA_DIST = org-gnome-tnef-attachments.eplug.xml