aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/templates/Makefile.am
diff options
context:
space:
mode:
authorBharath Acharya <abharath@novell.com>2008-07-21 02:26:42 +0800
committerBharath Acharya <abharath@src.gnome.org>2008-07-21 02:26:42 +0800
commit5948c36901a66021c7d3ded3acaf9bde18be17d2 (patch)
tree960806e80dea92c795ab98ace930034fdb8772ee /plugins/templates/Makefile.am
parent474f15f5571bc0d2e64785963703852f274e74df (diff)
downloadgsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar.gz
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar.bz2
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar.lz
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar.xz
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.tar.zst
gsoc2013-evolution-5948c36901a66021c7d3ded3acaf9bde18be17d2.zip
** Fixes Bug #200147
2008-07-18 Bharath Acharya <abharath@novell.com> ** Fixes Bug #200147 Basic functionality implemented by Diego Escalante Urrelo <diegoe@gnome.org> Everyone owes him a big mug of Beer for that. ** Added Templates plugin * Makefile.am: * apps-evolution-template-placeholders.schemas.in: * org-gnome-templates.eplug.xml: * templates.c: * templates.glade: svn path=/trunk/; revision=35780
Diffstat (limited to 'plugins/templates/Makefile.am')
-rw-r--r--plugins/templates/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/plugins/templates/Makefile.am b/plugins/templates/Makefile.am
new file mode 100644
index 0000000000..91da6c1ed9
--- /dev/null
+++ b/plugins/templates/Makefile.am
@@ -0,0 +1,40 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/composer \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_PLUGINDIR="\"$(plugindir)\""
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = \
+ org-gnome-templates.eplug \
+ templates.glade
+
+plugin_LTLIBRARIES = liborg-gnome-templates.la
+
+liborg_gnome_templates_la_SOURCES = templates.c
+liborg_gnome_templates_la_LDFLAGS = -module -avoid-version
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_in_files = apps-evolution-template-placeholders.schemas.in
+schema_DATA = $(schema_in_files:.schemas.in=.schemas)
+
+@INTLTOOL_SCHEMAS_RULE@
+
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
+ done \
+ fi
+
+EXTRA_DIST = org-gnome-templates.eplug.xml \
+ $(schema_in_files) \
+ templates.glade
+
+BUILT_SOURCES = org-gnome-templates.eplug
+
+CLEANFILES = $(BUILT_SOURCES)
+
+DISTCLEANFILES = $(schema_DATA)