aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/sa-junk-plugin/Makefile.am
diff options
context:
space:
mode:
authorVivek Jain <jvivek@novell.com>2005-07-06 13:20:38 +0800
committerJain Vivek <jvivek@src.gnome.org>2005-07-06 13:20:38 +0800
commitf1bb8634282308d6747f303454329345bdcf9e76 (patch)
treee1637c7451d938222695ea7b8efe7d2fe70551fb /plugins/sa-junk-plugin/Makefile.am
parent8cb64d5172526847b3d6da722c207924b836a066 (diff)
downloadgsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar.gz
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar.bz2
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar.lz
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar.xz
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.tar.zst
gsoc2013-evolution-f1bb8634282308d6747f303454329345bdcf9e76.zip
sa-junk-plugin : plugin that uses spam assasin for junk mail handling
2005-07-06 Vivek Jain <jvivek@novell.com> sa-junk-plugin : plugin that uses spam assasin for junk mail handling moved em-junk-filter.c from mail/ to here and modified it to listen to the callbacks from the plugin. svn path=/trunk/; revision=29645
Diffstat (limited to 'plugins/sa-junk-plugin/Makefile.am')
-rw-r--r--plugins/sa-junk-plugin/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/sa-junk-plugin/Makefile.am b/plugins/sa-junk-plugin/Makefile.am
new file mode 100644
index 0000000000..a3bf4e67f1
--- /dev/null
+++ b/plugins/sa-junk-plugin/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(EVOLUTION_MAIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-sa-junk-plugin.eplug
+plugin_LTLIBRARIES = liborg-gnome-sa-junk-plugin.la
+
+liborg_gnome_sa_junk_plugin_la_SOURCES = em-junk-filter.c
+liborg_gnome_sa_junk_plugin_la_LDFLAGS = -module -avoid-version
+
+
+BUILT_SOURCES = $(plugin_DATA) $(error_DATA)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = \
+ org-gnome-sa-junk-plugin.eplug.xml
+
+