aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/python/example/Makefile.am
diff options
context:
space:
mode:
authorJohnny Jacob <jjohnny@src.gnome.org>2008-06-12 05:22:15 +0800
committerJohnny Jacob <jjohnny@src.gnome.org>2008-06-12 05:22:15 +0800
commit49db161be97ce0ff71b8fa9fbdf2a00a45ded788 (patch)
tree6b6af1c2a7ba9a68c341145572b47644de8c4827 /plugins/python/example/Makefile.am
parenta8288ede3081f5dcad39f9c0fc71cf849045a6ec (diff)
downloadgsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar.gz
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar.bz2
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar.lz
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar.xz
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.tar.zst
gsoc2013-evolution-49db161be97ce0ff71b8fa9fbdf2a00a45ded788.zip
A simple example python plugin - just hook onto events.
svn path=/trunk/; revision=35627
Diffstat (limited to 'plugins/python/example/Makefile.am')
-rw-r--r--plugins/python/example/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/plugins/python/example/Makefile.am b/plugins/python/example/Makefile.am
new file mode 100644
index 0000000000..5defe418c6
--- /dev/null
+++ b/plugins/python/example/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\"
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = \
+ hello_python.py \
+ org-gnome-hello-python-ui.xml \
+ org-gnome-hello-python.eplug
+
+liborg_gnome_py_plug_test_la_LIBADD= \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
+
+liborg_gnome_py_plug_test_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
+errordir = $(privdatadir)/errors
+
+BUILDME = org-gnome-hello-python.eplug \
+$(error_i18n)
+
+BUILT_SOURCES = \
+ $(BUILDME)
+
+EXTRA_DIST = \
+ hello_python.py \
+ org-gnome-hello-python-ui.xml \
+ org-gnome-hello-python.eplug.xml
+
+CLEANFILES = $(BUILT_SOURCES)