aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/pst-import/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2009-01-29 03:35:22 +0800
committerTor Lillqvist <tml@src.gnome.org>2009-01-29 03:35:22 +0800
commitf81121629e979f6016e8dedecdb8a27da9080cd2 (patch)
tree18fe29b3c2a0c2b85526dd9b1f84e0013ed27d55 /plugins/pst-import/Makefile.am
parent94a4c02753aaff06fa2430e42a0394af550e2412 (diff)
downloadgsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar.gz
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar.bz2
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar.lz
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar.xz
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.tar.zst
gsoc2013-evolution-f81121629e979f6016e8dedecdb8a27da9080cd2.zip
On Windows use -no-undefined and link with all required libraries. (Just
2009-01-28 Tor Lillqvist <tml@novell.com> * Makefile.am: On Windows use -no-undefined and link with all required libraries. (Just throw in a bunch of libraries without cherry-picking. Having "superfluous" ones just slows down the linking a bit, but doesn't hurt at run-time.) Use LIBPST_CFLAGS. * pst-importer.c: Include <libpst/define.h> before the other libpst headers. Otherwise we get compilation errors on Windows, sigh. svn path=/trunk/; revision=37156
Diffstat (limited to 'plugins/pst-import/Makefile.am')
-rw-r--r--plugins/pst-import/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/plugins/pst-import/Makefile.am b/plugins/pst-import/Makefile.am
index 031b1b181e..9f3061e241 100644
--- a/plugins/pst-import/Makefile.am
+++ b/plugins/pst-import/Makefile.am
@@ -1,10 +1,19 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_CALENDAR_LIBS) \
+ $(EVOLUTION_MAIL_LIBS)
+endif
+
INCLUDES = \
-I$(EVOLUTION_SOURCE) \
-I$(top_srcdir) \
-DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
-DLOCALEDIR="\"$(LOCALEDIR)\"" \
$(EVOLUTION_CFLAGS) \
- $(EVOLUTION_MAIL_CFLAGS)
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(LIBPST_CFLAGS)
@EVO_PLUGIN_RULE@
@@ -12,8 +21,10 @@ plugin_DATA = org-gnome-pst-import.eplug
plugin_LTLIBRARIES = liborg-gnome-pst-import.la
liborg_gnome_pst_import_la_SOURCES = pst-importer.c
-liborg_gnome_pst_import_la_LDFLAGS = -module -avoid-version
-liborg_gnome_pst_import_la_LIBADD = \
+liborg_gnome_pst_import_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_pst_import_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS) \
$(LIBPST_LIBS)
EXTRA_DIST = org-gnome-pst-import.eplug.xml