aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/pst-import/Makefile.am
diff options
context:
space:
mode:
authorH.Habighorst <h.habighorst@googlemail.com>2009-10-01 11:37:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-10-01 11:37:50 +0800
commitf62728b55e201ea92e682e07b3253ce4fb42d5af (patch)
tree2083db9702cd5068e7fc4471c47086071e366015 /plugins/pst-import/Makefile.am
parentda3ae4fd5fa723abc4574d0459c761e76abba080 (diff)
downloadgsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.gz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.bz2
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.lz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.xz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.zst
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.zip
Bug 596848 - Use per-target CPPFLAGS in automake files
Diffstat (limited to 'plugins/pst-import/Makefile.am')
-rw-r--r--plugins/pst-import/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/plugins/pst-import/Makefile.am b/plugins/pst-import/Makefile.am
index 7c4ace9a21..f120065f9a 100644
--- a/plugins/pst-import/Makefile.am
+++ b/plugins/pst-import/Makefile.am
@@ -6,7 +6,14 @@ NO_UNDEFINED_REQUIRED_LIBS = \
$(EVOLUTION_MAIL_LIBS)
endif
-AM_CPPFLAGS = \
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-pst-import.eplug
+
+plugin_LTLIBRARIES = liborg-gnome-pst-import.la
+
+liborg_gnome_pst_import_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-I$(top_builddir) \
@@ -17,14 +24,10 @@ AM_CPPFLAGS = \
$(EVOLUTION_MAIL_CFLAGS) \
$(LIBPST_CFLAGS)
-@EVO_PLUGIN_RULE@
+liborg_gnome_pst_import_la_SOURCES = pst-importer.c
-plugin_DATA = org-gnome-pst-import.eplug
-plugin_LTLIBRARIES = liborg-gnome-pst-import.la
+liborg_gnome_pst_import_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
-liborg_gnome_pst_import_la_SOURCES = pst-importer.c
-liborg_gnome_pst_import_la_LDFLAGS = \
- -module -avoid-version $(NO_UNDEFINED)
liborg_gnome_pst_import_la_LIBADD = \
$(top_builddir)/mail/libevolution-mail.la \
$(GNOME_PLATFORM_LIBS) \