aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2005-05-24 17:39:24 +0800
committerMichael Zucci <zucchi@src.gnome.org>2005-05-24 17:39:24 +0800
commitc33282a6549d7f7d64a27a9d14e6e99b114053b9 (patch)
treea1e58438c102e24de7a38cb86cce1896802f4df2 /plugins/mail-remote/Makefile.am
parent0822a01317ed088a14aa9268f1d086ff73cb423c (diff)
downloadgsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar.gz
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar.bz2
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar.lz
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar.xz
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.tar.zst
gsoc2013-evolution-c33282a6549d7f7d64a27a9d14e6e99b114053b9.zip
Lots more work. Now implements a full listener interface. Filled out api.
2005-05-24 Not Zed <NotZed@Ximian.com> * Lots more work. Now implements a full listener interface. Filled out api. svn path=/trunk/; revision=29406
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
index ccdcae2348..8a43ea3473 100644
--- a/plugins/mail-remote/Makefile.am
+++ b/plugins/mail-remote/Makefile.am
@@ -23,6 +23,8 @@ liborg_gnome_evolution_mail_remote_la_SOURCES = \
evolution-mail-session.h \
evolution-mail-store.c \
evolution-mail-store.h \
+ evolution-mail-marshal.c \
+ evolution-mail-marshal.h \
mail-remote.c
liborg_gnome_evolution_mail_remote_la_LDFLAGS = -module -avoid-version
@@ -33,6 +35,7 @@ client_SOURCES = \
client_LDADD = \
$(EVOLUTION_MAIL_LIBS) \
evolution-mail-listener.o \
+ evolution-mail-marshal.o \
Evolution-DataServer-Mail-common.o \
Evolution-DataServer-Mail-stubs.o \
Evolution-DataServer-Mail-skels.o
@@ -59,8 +62,13 @@ $(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
#idl_DATA = $(IDL)
+# marshallers for glib
+MARSHAL_GENERATED = evolution-mail-marshal.c evolution-mail-marshal.h
+@EVO_MARSHAL_RULE@
+
EXTRA_DIST = \
- $(IDL)
+ $(IDL) \
+ evolution-mail-marshal.list
-BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C)
+BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C) $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)