aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2005-06-02 13:51:16 +0800
committerMichael Zucci <zucchi@src.gnome.org>2005-06-02 13:51:16 +0800
commit79086a141808831e3d7e49969f507678d08e6bec (patch)
treeeb902b70042566058ba2d8a0c78b32221e419085 /plugins/mail-remote/Makefile.am
parent84dd2e3f792d59dadacb9eb3bea0ad719002643a (diff)
downloadgsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar.gz
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar.bz2
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar.lz
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar.xz
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.tar.zst
gsoc2013-evolution-79086a141808831e3d7e49969f507678d08e6bec.zip
seutp an idl file so we only need to generate one set of skels/stubs for
2005-06-02 Not Zed <NotZed@Ximian.com> * Evolution.idl: seutp an idl file so we only need to generate one set of skels/stubs for all imported. * mail-remote.c (e_plugin_lib_enable): instead of writing ior to a file, just add the Session interface to the mail component. * client.c (get_session): use the new shell interface to find the mail compnent and retrieve the session interface using bonobo-activation, so the mailer starts if we try to access it. svn path=/trunk/; revision=29445
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
index 80fb0fcc97..800cf71dc6 100644
--- a/plugins/mail-remote/Makefile.am
+++ b/plugins/mail-remote/Makefile.am
@@ -49,7 +49,9 @@ client_LDADD = \
evolution-mail-messagestream.o \
Evolution-DataServer-Mail-common.o \
Evolution-DataServer-Mail-stubs.o \
- Evolution-DataServer-Mail-skels.o
+ Evolution-DataServer-Mail-skels.o \
+ Evolution-common.o \
+ Evolution-stubs.o
noinst_PROGRAMS = \
client
@@ -66,9 +68,14 @@ IDL_GENERATED_C = \
Evolution-DataServer-Mail-skels.c \
Evolution-DataServer-Mail-stubs.c
+EVO_GENERATED = Evolution.h Evolution-common.c Evolution-stubs.c Evolution-skels.c
+
$(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $^
+$(EVO_GENERATED): $(srcdir)/Evolution.idl
+ $(ORBIT_IDL) -I $(top_srcdir) -I $(top_srcdir)/shell -I $(datadir)/idl $(IDL_INCLUDES) $^
+
# installed idls
#idl_DATA = $(IDL)
@@ -79,7 +86,8 @@ MARSHAL_GENERATED = evolution-mail-marshal.c evolution-mail-marshal.h
EXTRA_DIST = \
$(IDL) \
+ Evolution.idl \
evolution-mail-marshal.list
-BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C) $(MARSHAL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C) $(MARSHAL_GENERATED) $(SHELL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)