aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
authorMichael Zucci <zucchi@src.gnome.org>2005-05-04 13:37:51 +0800
committerMichael Zucci <zucchi@src.gnome.org>2005-05-04 13:37:51 +0800
commit3509757d148d80a78a942b1e3938bead90b5d506 (patch)
treec99d23b07961365d554eb78e5e77ecbdb3016b1c /plugins/mail-remote/Makefile.am
parentf56ef1dbe184bc792c301092ff91d3d92fb48371 (diff)
downloadgsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar.gz
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar.bz2
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar.lz
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar.xz
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.tar.zst
gsoc2013-evolution-3509757d148d80a78a942b1e3938bead90b5d506.zip
Initial work on remote mail interface, as a plugin.
svn path=/trunk/; revision=29265
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
new file mode 100644
index 0000000000..25653f666b
--- /dev/null
+++ b/plugins/mail-remote/Makefile.am
@@ -0,0 +1,35 @@
+
+
+# mail idl
+
+IDL = Evolution-DataServer-Mail.idl
+
+IDL_GENERATED_H = \
+ Evolution-DataServer-Mail.h
+
+IDL_GENERATED_C = \
+ Evolution-DataServer-Mail-common.c \
+ Evolution-DataServer-Mail-skels.c \
+ Evolution-DataServer-Mail-stubs.c
+
+$(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
+ $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $^
+
+# installed idls
+
+idl_DATA = $(IDL)
+
+_SOURCES = \
+ $(IDL_GENERATED_C) \
+ $(IDL_GENERATED_H) \
+ evolution-mail-folder.c \
+ evolution-mail-folder.h \
+ evolution-mail-session.c \
+ evolution-mail-session.h \
+ evolution-mail-store.c \
+ evolution-mail-store.h
+
+EXTRA_DIST = \
+ $(IDL)
+
+BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C)