aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-notification/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@src.gnome.org>2007-05-03 16:04:47 +0800
committerSrinivasa Ragavan <sragavan@src.gnome.org>2007-05-03 16:04:47 +0800
commitca40a11a3c196c24fb122bad0a831d07e8748b80 (patch)
tree99de2c0688c0e2d72dde5b0f4392cf0b9756b0cc /plugins/mail-notification/Makefile.am
parentb92eff4a79b7210ea699e6d857c6126003aa5d16 (diff)
downloadgsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar.gz
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar.bz2
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar.lz
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar.xz
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.tar.zst
gsoc2013-evolution-ca40a11a3c196c24fb122bad0a831d07e8748b80.zip
Initial commit for Mail notification plugin.
svn path=/trunk/; revision=33474
Diffstat (limited to 'plugins/mail-notification/Makefile.am')
-rw-r--r--plugins/mail-notification/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/mail-notification/Makefile.am b/plugins/mail-notification/Makefile.am
new file mode 100644
index 0000000000..6644bf97b5
--- /dev/null
+++ b/plugins/mail-notification/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -DDBUS_API_SUBJECT_TO_CHANGE=1 \
+ -DDBUS_VERSION=$(DBUS_VERSION) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(LIBNOTIFY_CFLAGS)
+ $(NMN_CFLAGS)
+
+LIBS = \
+ $(LIBNOTIFY_LIBS) \
+ $(NMN_LIBS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-mail-notification.eplug
+plugin_LTLIBRARIES = liborg-gnome-mail-notification.la
+
+liborg_gnome_mail_notification_la_SOURCES = mail-notification.c
+liborg_gnome_mail_notification_la_LDFLAGS = -module -avoid-version
+
+EXTRA_DIST = org-gnome-mail-notification.eplug.xml
+
+BUILT_SOURCES = $(plugin_DATA)
+CLEANFILES = $(BUILT_SOURCES)