aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/import-ics-attachments/Makefile.am
diff options
context:
space:
mode:
authorHarish Krishnaswamy <kharish@novell.com>2006-01-17 14:47:57 +0800
committerHarish Krishnaswamy <kharish@src.gnome.org>2006-01-17 14:47:57 +0800
commit7125df895648af3113917f75c5f6f40d6b769197 (patch)
tree208b43bd8c69578a8abb44793f78059f07840a74 /plugins/import-ics-attachments/Makefile.am
parent8bcc31b5931025ecae29920ae4867f282b1914bb (diff)
downloadgsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar.gz
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar.bz2
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar.lz
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar.xz
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.tar.zst
gsoc2013-evolution-7125df895648af3113917f75c5f6f40d6b769197.zip
Initial commits. Plugin written and submitted by Johnny Jacob
2006-01-17 Harish Krishnaswamy <kharish@novell.com> * import-ics-attachments : Initial commits. Plugin written and submitted by Johnny Jacob <johnnyjacob@gmail.com> svn path=/trunk/; revision=31223
Diffstat (limited to 'plugins/import-ics-attachments/Makefile.am')
-rw-r--r--plugins/import-ics-attachments/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/import-ics-attachments/Makefile.am b/plugins/import-ics-attachments/Makefile.am
new file mode 100644
index 0000000000..c73177db92
--- /dev/null
+++ b/plugins/import-ics-attachments/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = \
+ -I$(top_srcdir)\
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/widgets/misc \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
+ -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
+ -DPLUGINDIR=\""$(plugindir)"\" \
+ -DPREFIX=\""$(prefix)"\"
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-evolution-mail-attachments-import-ics.eplug
+plugin_LTLIBRARIES = liborg-gnome-evolution-mail-attachments-import-ics.la
+
+liborg_gnome_evolution_mail_attachments_import_ics_la_SOURCES = icsimporter.c
+liborg_gnome_evolution_mail_attachments_import_ics_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_evolution_mail_attachments_import_ics_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(EVOLUTION_MAIL_LIBS)
+
+EXTRA_DIST = org-gnome-evolution-mail-attachments-import-ics.eplug.xml