aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/image-inline/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-11-08 11:09:32 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-11-10 08:57:09 +0800
commit6db0e254190a80cf1cccb3629442b78e76c55b36 (patch)
tree7d3199173472fb0d4efc70f1ca6ecb56f75fccb4 /plugins/image-inline/Makefile.am
parent214f3a8038667a7bf75c379b91a8a687095d4d05 (diff)
downloadgsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar.gz
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar.bz2
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar.lz
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar.xz
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.tar.zst
gsoc2013-evolution-6db0e254190a80cf1cccb3629442b78e76c55b36.zip
Prototype an inline image plugin.
Uses GtkImageView to display the image.
Diffstat (limited to 'plugins/image-inline/Makefile.am')
-rw-r--r--plugins/image-inline/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/image-inline/Makefile.am b/plugins/image-inline/Makefile.am
new file mode 100644
index 0000000000..5ff7c260eb
--- /dev/null
+++ b/plugins/image-inline/Makefile.am
@@ -0,0 +1,29 @@
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-image-inline.eplug
+
+plugin_LTLIBRARIES = liborg-gnome-image-inline.la
+
+liborg_gnome_image_inline_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(GTKIMAGEVIEW_CFLAGS)
+
+liborg_gnome_image_inline_la_SOURCES = image-inline.c
+
+liborg_gnome_image_inline_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
+liborg_gnome_image_inline_la_LIBADD = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(GTKIMAGEVIEW_LIBS) \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+EXTRA_DIST = org-gnome-image-inline.eplug.xml
+
+BUILT_SOURCES = $(plugin_DATA)
+CLEANFILES = $(BUILT_SOURCES)
+
+-include $(top_srcdir)/git.mk