aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/external-editor/Makefile.am
diff options
context:
space:
mode:
authorSankar P <psankar@novell.com>2007-10-25 18:44:27 +0800
committerSankarasivasubramanian Pasupathilingam <psankar@src.gnome.org>2007-10-25 18:44:27 +0800
commit820424bc8ce8f284b72adced8729120373b55ee3 (patch)
treec906640a9e2b10b0f373aa28fc1170cfbb08286d /plugins/external-editor/Makefile.am
parentfaae84477af9ba732358930d7d6ba57f16c4a6df (diff)
downloadgsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar.gz
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar.bz2
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar.lz
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar.xz
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.tar.zst
gsoc2013-evolution-820424bc8ce8f284b72adced8729120373b55ee3.zip
Added new plugins external-editor, which will make it possible to use an
2007-10-25 Sankar P <psankar@novell.com> * configure.in: * plugins/external-editor: Added new plugins external-editor, which will make it possible to use an external editor as the mail composer. svn path=/trunk/; revision=34423
Diffstat (limited to 'plugins/external-editor/Makefile.am')
-rw-r--r--plugins/external-editor/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/plugins/external-editor/Makefile.am b/plugins/external-editor/Makefile.am
new file mode 100644
index 0000000000..beec48dc29
--- /dev/null
+++ b/plugins/external-editor/Makefile.am
@@ -0,0 +1,38 @@
+INCLUDES = \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/composer \
+ $(SHELL_CFLAGS) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(E_UTIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+error_DATA = org-gnome-external-editor.error
+errordir = $(privdatadir)/errors
+
+plugin_DATA = \
+ org-gnome-external-editor.eplug \
+ org-gnome-external-editor.xml
+
+plugin_LTLIBRARIES = liborg-gnome-external-editor.la
+
+liborg_gnome_external_editor_la_SOURCES = \
+ external-editor.c
+
+liborg_gnome_external_editor_la_LDFLAGS = -module -avoid-version
+
+EXTRA_DIST = \
+ org-gnome-external-editor.eplug.xml \
+ org-gnome-external-editor.error.xml \
+ org-gnome-external-editor.xml
+
+BUILT_SOURCES = org-gnome-external-editor.eplug \
+ org-gnome-external-editor.error
+
+CLEANFILES = $(BUILT_SOURCES)