aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/external-editor/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2009-01-29 01:24:15 +0800
committerTor Lillqvist <tml@src.gnome.org>2009-01-29 01:24:15 +0800
commitaf20d5634343bba3ac1fa57888db86c29b07a868 (patch)
tree0021ea84fc576647dde030301ccd904a9e73c541 /plugins/external-editor/Makefile.am
parent0dfe01e99b855b7c027136f0f6e6de5b004b46ae (diff)
downloadgsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar.gz
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar.bz2
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar.lz
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar.xz
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.tar.zst
gsoc2013-evolution-af20d5634343bba3ac1fa57888db86c29b07a868.zip
Windows port by Fridrich Strba.
2009-01-28 Tor Lillqvist <tml@novell.com> Windows port by Fridrich Strba. * Makefile.am: Use -no-undefined and link with more libraries on Windows. * external-editor.c: Check HAVE_SYS_WAIT_H. svn path=/trunk/; revision=37150
Diffstat (limited to 'plugins/external-editor/Makefile.am')
-rw-r--r--plugins/external-editor/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/plugins/external-editor/Makefile.am b/plugins/external-editor/Makefile.am
index 0c7c22ab8b..bae2c640a5 100644
--- a/plugins/external-editor/Makefile.am
+++ b/plugins/external-editor/Makefile.am
@@ -1,3 +1,11 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la
+endif
+
INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
@@ -25,7 +33,10 @@ plugin_LTLIBRARIES = liborg-gnome-external-editor.la
liborg_gnome_external_editor_la_SOURCES = \
external-editor.c
-liborg_gnome_external_editor_la_LDFLAGS = -module -avoid-version
+liborg_gnome_external_editor_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_external_editor_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_in_files = apps-evolution-external-editor.schemas.in