aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/exchange-operations/Makefile.am
diff options
context:
space:
mode:
authorSarfraaz Ahmed <asarfraaz@novell.com>2005-07-11 15:16:42 +0800
committerAhmed Sarfraaz <sarfraaz@src.gnome.org>2005-07-11 15:16:42 +0800
commit4dbbd163dd4a8866e9547ff40002b34ade4ff3b1 (patch)
tree04aac693323367be1ab12c38e528c553544726ba /plugins/exchange-operations/Makefile.am
parent21eb448cadb620929c16b8ca732bd759ac4d74bb (diff)
downloadgsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar.gz
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar.bz2
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar.lz
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar.xz
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.tar.zst
gsoc2013-evolution-4dbbd163dd4a8866e9547ff40002b34ade4ff3b1.zip
Patch submitted by ArunPrakash <arunp@novell.com> Newly added, to report
2005-07-11 Sarfraaz Ahmed <asarfraaz@novell.com> Patch submitted by ArunPrakash <arunp@novell.com> * exchange-operations.c (exchange_operations_report_error) : Newly added, to report errors using e_error_run. Also a list of error-ids is added. * exchange-config-listener.c (account_added) (account_removed) : Modified the usage of e_notice to e_error_run. Also the error from exchange_account_connect is reported using exchange_operations_report_error. * exchange-account-setup.c (btn_chpass_clicked) (org_gnome_exchange_settings) (print_error) (set_oof_info): Changed to use exchange_operations_report_error and e_error_run functions. * org-gnome-exchange-operations.error.xml : Newly added, defines the list of error messages used in the plugin. * Makefile.am : Modified for org-gnome-exchange-operations.error.xml svn path=/trunk/; revision=29707
Diffstat (limited to 'plugins/exchange-operations/Makefile.am')
-rw-r--r--plugins/exchange-operations/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugins/exchange-operations/Makefile.am b/plugins/exchange-operations/Makefile.am
index 727560fc72..1d270478bb 100644
--- a/plugins/exchange-operations/Makefile.am
+++ b/plugins/exchange-operations/Makefile.am
@@ -55,9 +55,14 @@ glade_DATA = \
exchange-folder-tree.glade \
exchange-permissions-dialog.glade
+error_DATA = org-gnome-exchange-operations.error
+errordir = $(privdatadir)/errors
+
EXTRA_DIST = \
org-gnome-exchange-operations.eplug.in \
+ org-gnome-exchange-operations.error.xml \
org-gnome-folder-permissions.xml \
org-gnome-folder-subscription.xml \
- $(glade_DATA)
+ $(glade_DATA)
+BUILT_SOURCES = $(error_DATA)