aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/exchange-operations/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2009-09-25 16:25:40 +0800
committerMilan Crha <mcrha@redhat.com>2009-09-25 16:25:40 +0800
commit17ccb42efb09717a26d7bfceee7a18ad67d71411 (patch)
tree4db7bf42635c9169734a5880c6609a3fa111d5e4 /plugins/exchange-operations/Makefile.am
parenta60c3f37361f5ce5d1b108286ab502232360c522 (diff)
downloadgsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar.gz
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar.bz2
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar.lz
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar.xz
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.tar.zst
gsoc2013-evolution-17ccb42efb09717a26d7bfceee7a18ad67d71411.zip
Bug #593609 - Have buildable exchange-operations plugin again
Diffstat (limited to 'plugins/exchange-operations/Makefile.am')
-rw-r--r--plugins/exchange-operations/Makefile.am31
1 files changed, 4 insertions, 27 deletions
diff --git a/plugins/exchange-operations/Makefile.am b/plugins/exchange-operations/Makefile.am
index 933da521a1..1e7cdd1deb 100644
--- a/plugins/exchange-operations/Makefile.am
+++ b/plugins/exchange-operations/Makefile.am
@@ -5,19 +5,12 @@ AM_CPPFLAGS = -I . \
-I$(top_builddir)/composer \
-I$(top_builddir)/mail \
$(CAMEL_EXCHANGE_CFLAGS) \
- $(EVOLUTION_MAIL_CFLAGS) \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DCONNECTOR_GLADEDIR=\""$(gladedir)"\"
+ $(EVOLUTION_MAIL_CFLAGS)
@EVO_PLUGIN_RULE@
-plugin_DATA = org-gnome-exchange-operations.eplug \
- org-gnome-folder-permissions.xml \
- org-gnome-folder-subscription.xml \
- org-gnome-exchange-tasks-subscription.xml \
- org-gnome-exchange-cal-subscription.xml \
- org-gnome-exchange-ab-subscription.xml
+plugin_DATA = org-gnome-exchange-operations.eplug
plugin_LTLIBRARIES = liborg-gnome-exchange-operations.la
@@ -52,36 +45,20 @@ liborg_gnome_exchange_operations_la_SOURCES = \
liborg_gnome_exchange_operations_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/shell/libeshell.la \
$(top_builddir)/calendar/gui/libevolution-calendar.la \
$(top_builddir)/mail/libevolution-mail.la \
- $(top_builddir)/addressbook/gui/component/libevolution-addressbook.la \
$(CAMEL_EXCHANGE_LIBS) \
$(EVOLUTION_MAIL_LIBS)
liborg_gnome_exchange_operations_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
-glade_DATA = \
- exchange-change-password.glade \
- exchange-delegates.glade \
- exchange-folder-tree.glade \
- exchange-permissions-dialog.glade \
- e-foreign-folder-dialog.glade \
- exchange-passwd-expiry.glade \
- exchange-oof.glade \
- exchange-send-options.glade
-
error_DATA = org-gnome-exchange-operations.error
errordir = $(privdatadir)/errors
EXTRA_DIST = \
org-gnome-exchange-operations.eplug.xml \
- org-gnome-exchange-operations.error.xml \
- org-gnome-folder-permissions.xml \
- org-gnome-folder-subscription.xml \
- org-gnome-exchange-tasks-subscription.xml \
- org-gnome-exchange-cal-subscription.xml \
- org-gnome-exchange-ab-subscription.xml \
- $(glade_DATA)
+ org-gnome-exchange-operations.error.xml
BUILT_SOURCES = $(error_DATA) org-gnome-exchange-operations.eplug