aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/contacts-map/Makefile.am
diff options
context:
space:
mode:
authorCedric Bosdonnat <cedric.bosdonnat.ooo@free.fr>2009-11-27 05:05:12 +0800
committerMilan Crha <mcrha@redhat.com>2009-11-27 05:07:45 +0800
commit93b157843473065b73cbaa99e998f57d39f189ad (patch)
tree57ab70a35a3f5c99b25aefae606cccb1a6244eb4 /plugins/contacts-map/Makefile.am
parente64794f577ab4bf9ffed0eb88e432ff75ecddd8f (diff)
downloadgsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar.gz
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar.bz2
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar.lz
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar.xz
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.tar.zst
gsoc2013-evolution-93b157843473065b73cbaa99e998f57d39f189ad.zip
Bug #361156 - contacts-map plugin
Add a map showing the location of contacts when possible. It's disabled at the moment.
Diffstat (limited to 'plugins/contacts-map/Makefile.am')
-rw-r--r--plugins/contacts-map/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/plugins/contacts-map/Makefile.am b/plugins/contacts-map/Makefile.am
new file mode 100644
index 0000000000..91ff22c0bc
--- /dev/null
+++ b/plugins/contacts-map/Makefile.am
@@ -0,0 +1,31 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ $(EVOLUTION_ADDRESSBOOK_CFLAGS) \
+ $(CHAMPLAIN_CFLAGS) \
+ $(GEOCLUE_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-contacts-map.eplug
+plugin_LTLIBRARIES = liborg-gnome-contacts-map.la
+
+liborg_gnome_contacts_map_la_SOURCES = \
+ contacts-map.c \
+ geo-utils.c \
+ geo-utils.h
+
+liborg_gnome_contacts_map_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_contacts_map_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(CHAMPLAIN_LIBS) \
+ $(GEOCLUE_LIBS) \
+ $(EVOLUTION_ADDRESSBOOK_LIBS)
+
+EXTRA_DIST = org-gnome-contacts-maps.eplug.xml
+
+BUILT_SOURCES = $(plugin_DATA)
+CLEANFILES = $(BUILT_SOURCES)
+
+-include $(top_srcdir)/git.mk