aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
authorRodrigo Moya <rodrigo@novell.com>2005-01-08 00:28:15 +0800
committerRodrigo Moya <rodrigo@src.gnome.org>2005-01-08 00:28:15 +0800
commit621fa441983c036519b49a8a200c9ee69715856b (patch)
treeca5efab4b9fbc751c678f12e99baf693ca09071e /plugins/calendar-weather/Makefile.am
parent16167b179d26cdb8b2ff0dcb1503b93e5e56815a (diff)
downloadgsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar.gz
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar.bz2
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar.lz
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar.xz
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.tar.zst
gsoc2013-evolution-621fa441983c036519b49a8a200c9ee69715856b.zip
define EDS's datadir, needed to get to the Locations.xml file.
2005-01-07 Rodrigo Moya <rodrigo@novell.com> * Makefile.am: define EDS's datadir, needed to get to the Locations.xml file. * calendar-weather.c (load_locations): use EDS's datadir for the Locations.xml file full path. svn path=/trunk/; revision=28273
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
index a7fb297d74..ef4e0a0b7b 100644
--- a/plugins/calendar-weather/Makefile.am
+++ b/plugins/calendar-weather/Makefile.am
@@ -1,15 +1,18 @@
-INCLUDES = \
- -I$(top_srcdir)/shell \
- $(EVOLUTION_CFLAGS) \
- $(EVOLUTION_CALENDAR_CFLAGS) \
- $(SOURCE_SEL_CFLAGS) \
- -DWEATHER_DATADIR=\""$(datadir)/weather"\"
+eds_datadir = `pkg-config --variable=privdatadir evolution-data-server-1.2`
+
+INCLUDES = \
+ -I$(top_srcdir)/shell \
+ $(EVOLUTION_CFLAGS) \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(SOURCE_SEL_CFLAGS) \
+ -DWEATHER_DATADIR=\""$(datadir)/evolution-$(BASE_VERSION)/weather"\" \
+ -DWEATHER_EDS_DATADIR=\""$(eds_datadir)/weather"\"
@EVO_PLUGIN_RULE@
# These will actually install into the e-d-s share directory, but
# if the plugin is disabled, we aren't going to be needing them.
-weatherdatadir = $(datadir)/weather
+weatherdatadir = $(datadir)/evolution-$(BASE_VERSION)/weather
weatherdata_DATA = \
category_weather_cloudy_16.png \
category_weather_fog_16.png \