aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2008-12-03 20:28:57 +0800
committerMilan Crha <mcrha@src.gnome.org>2008-12-03 20:28:57 +0800
commit792772dc246fe7d2119f946a2ea95a70256fb147 (patch)
treeedf35d2afc3982b67b72da945e06109ab0298200 /plugins/calendar-weather/Makefile.am
parent4bec962f7b5cd2a65bed33de3e8f56f3b2b4bad7 (diff)
downloadgsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar.gz
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar.bz2
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar.lz
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar.xz
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.tar.zst
gsoc2013-evolution-792772dc246fe7d2119f946a2ea95a70256fb147.zip
** Part of fix for bug #352287
2008-12-03 Milan Crha <mcrha@redhat.com> ** Part of fix for bug #352287 * calendar/gui/e-day-view-top-item.c: (e_day_view_top_item_draw_long_event): Draw top icons in full detail/color depth (for weather, for example). * plugins/calendar-weather/Makefile.am: Compile and link with libgweather. * plugins/calendar-weather/calendar-weather.c: (e_plugin_lib_enable), (selection_changed), (find_location_func), (find_location), (treeview_clicked), (create_source_selector), (build_location_path), (location_clicked), (e_calendar_weather_location): Use libgweather for weather calendar. Note: Requires eds revision at least 9793. svn path=/trunk/; revision=36827
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
index 8f57db1dcc..b5a811118c 100644
--- a/plugins/calendar-weather/Makefile.am
+++ b/plugins/calendar-weather/Makefile.am
@@ -1,5 +1,7 @@
eds_datadir = `pkg-config --variable=privdatadir evolution-data-server-1.2`
weatherdatadir = $(datadir)/evolution/$(BASE_VERSION)/weather
+LIBGWEATHER_CFLAGS = `pkg-config --cflags gweather`
+LIBGWEATHER_LIBS = `pkg-config --libs gweather`
INCLUDES = \
-I$(top_srcdir) \
@@ -7,7 +9,8 @@ INCLUDES = \
$(EVOLUTION_CALENDAR_CFLAGS) \
$(SOURCE_SEL_CFLAGS) \
-DWEATHER_DATADIR=\""$(weatherdatadir)"\" \
- -DWEATHER_EDS_DATADIR=\""$(eds_datadir)/weather"\"
+ -DWEATHER_EDS_DATADIR=\""$(eds_datadir)/weather"\" \
+ $(LIBGWEATHER_CFLAGS)
@EVO_PLUGIN_RULE@
@@ -24,12 +27,12 @@ plugin_DATA = org-gnome-calendar-weather.eplug
plugin_LTLIBRARIES = liborg-gnome-calendar-weather.la
liborg_gnome_calendar_weather_la_SOURCES = calendar-weather.c
-liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
-liborg_gnome_calendar_weather_la_LIBADD = \
+liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED) $(LIBGWEATHER_LIBS)
+liborg_gnome_calendar_weather_la_LIBADD = \
$(top_builddir)/calendar/gui/libevolution-calendar.la \
$(EVOLUTION_CALENDAR_LIBS)
-EXTRA_DIST = \
+EXTRA_DIST = \
org-gnome-calendar-weather.eplug.xml \
$(weatherdata_DATA)