aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
authorDavid Trowbridge <trowbrds@cs.colorado.edu>2005-01-07 19:35:33 +0800
committerRodrigo Moya <rodrigo@src.gnome.org>2005-01-07 19:35:33 +0800
commitc1d17ad26db6796ad5896ca67d82b489e99f55b5 (patch)
treefd9edc5c6706a54e009c288737cb2c62b7b9ace3 /plugins/calendar-weather/Makefile.am
parenta905f182cebf36afd4c26f40de1dd5375c45265d (diff)
downloadgsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar.gz
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar.bz2
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar.lz
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar.xz
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.tar.zst
gsoc2013-evolution-c1d17ad26db6796ad5896ca67d82b489e99f55b5.zip
Initial import of weather properties plugin
2004-01-06 David Trowbridge <trowbrds@cs.colorado.edu> * Initial import of weather properties plugin svn path=/trunk/; revision=28265
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
new file mode 100644
index 0000000000..ef17a5314b
--- /dev/null
+++ b/plugins/calendar-weather/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = \
+ -I$(top_srcdir)/shell \
+ $(EVOLUTION_CFLAGS) \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(SOURCE_SEL_CFLAGS) \
+ -DWEATHER_DATADIR=\""$(weatherdatadir)"\"
+
+@EVO_PLUGIN_RULE@
+
+# These will actually install into the e-d-s share directory, but
+# if the plugin is disabled, we aren't going to be needing them.
+weatherdata_DATA = \
+ category_weather_cloudy_16.png \
+ category_weather_fog_16.png \
+ category_weather_partly_cloudy_16.png \
+ category_weather_rain_16.png \
+ category_weather_snow_16.png \
+ category_weather_sun_16.png \
+ category_weather_tstorm_16.png
+
+plugin_DATA = org-gnome-calendar-weather.eplug
+plugin_LTLIBRARIES = liborg-gnome-calendar-weather.la
+
+liborg_gnome_calendar_weather_la_SOURCES = calendar-weather.c
+liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version
+
+EXTRA_DIST = \
+ org-gnome-calendar-weather.eplug.in \
+ $(weatherdata_DATA)