aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/bbdb/Makefile.am
diff options
context:
space:
mode:
authorNat Friedman <nat@novell.com>2004-10-26 11:02:04 +0800
committerNat Friedman <nat@src.gnome.org>2004-10-26 11:02:04 +0800
commitb40eb4903c03a3025cc513c04da70209c099d0c3 (patch)
tree3206e437caa92677b78fac8c580c75891f74b5cd /plugins/bbdb/Makefile.am
parent58519e7cec5c94bc0c2064c260718565c0c6e489 (diff)
downloadgsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar.gz
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar.bz2
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar.lz
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar.xz
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.tar.zst
gsoc2013-evolution-b40eb4903c03a3025cc513c04da70209c099d0c3.zip
Sync the Gaim buddy list. Set a timer to check for Gaim buddy list chnages
2004-10-25 Nat Friedman <nat@novell.com> * bbdb.c (e_plugin_lib_enable): Sync the Gaim buddy list. Set a timer to check for Gaim buddy list chnages to sync. (bbdb_do_it): Free some memory we were leaking before. (bbdb_open_addressbook): New function for Gaim buddy list support. (bbdb_check_gaim_enabled): Likewise. (enable_gaim_toggled_cb): Likewise. (synchronize_button_clicked_cb): Likewise. (bbdb_page_factory): Added UI for Gaim buddy list sync support. * gaimbuddies.c: New file, contains routines to synchronize IM information and buddy icons from a Gaim buddy list. * bbdb.h: New file, contains shared macros and prototypes. * test-evobuddy.c (main): New function, tests a gaim buddy list sync. svn path=/trunk/; revision=27723
Diffstat (limited to 'plugins/bbdb/Makefile.am')
-rw-r--r--plugins/bbdb/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/plugins/bbdb/Makefile.am b/plugins/bbdb/Makefile.am
index 140cc9e2fc..aa84ee194d 100644
--- a/plugins/bbdb/Makefile.am
+++ b/plugins/bbdb/Makefile.am
@@ -8,5 +8,11 @@ INCLUDES = \
plugin_DATA = org-gnome-evolution-bbdb.eplug
plugin_LTLIBRARIES = liborg-gnome-evolution-bbdb.la
-liborg_gnome_evolution_bbdb_la_SOURCES = bbdb.c
+liborg_gnome_evolution_bbdb_la_SOURCES = bbdb.c gaimbuddies.c
liborg_gnome_evolution_bbdb_la_LDFLAGS = -module -avoid-version
+
+noinst_PROGRAMS = test-evobuddy
+
+test_evobuddy_LDADD = $(top_builddir)/camel/libcamel.la $(EVOLUTION_ADDRESSBOOK_LIBS) $(EVOLUTION_MAIL_LIBS) $(CAMEL_LIBS)
+test_evobuddy_SOURCES = test-evobuddy.c gaimbuddies.c bbdb.c
+test_evobuddy_INCLUDES = $(INCLUDES)