aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/bbdb/Makefile.am
diff options
context:
space:
mode:
authorH.Habighorst <h.habighorst@googlemail.com>2009-10-01 11:37:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-10-01 11:37:50 +0800
commitf62728b55e201ea92e682e07b3253ce4fb42d5af (patch)
tree2083db9702cd5068e7fc4471c47086071e366015 /plugins/bbdb/Makefile.am
parentda3ae4fd5fa723abc4574d0459c761e76abba080 (diff)
downloadgsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.gz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.bz2
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.lz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.xz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.zst
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.zip
Bug 596848 - Use per-target CPPFLAGS in automake files
Diffstat (limited to 'plugins/bbdb/Makefile.am')
-rw-r--r--plugins/bbdb/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/plugins/bbdb/Makefile.am b/plugins/bbdb/Makefile.am
index 0a44dc0c26..4f1d9066cf 100644
--- a/plugins/bbdb/Makefile.am
+++ b/plugins/bbdb/Makefile.am
@@ -5,20 +5,24 @@ NO_UNDEFINED_REQUIRED_LIBS = \
$(GNOME_PLATFORM_LIBS)
endif
-AM_CPPFLAGS = \
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-evolution-bbdb.eplug
+
+plugin_LTLIBRARIES = liborg-gnome-evolution-bbdb.la
+
+liborg_gnome_evolution_bbdb_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-I$(top_builddir)/composer \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
$(EVOLUTION_MAIL_CFLAGS) \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-@EVO_PLUGIN_RULE@
-
-plugin_DATA = org-gnome-evolution-bbdb.eplug
-plugin_LTLIBRARIES = liborg-gnome-evolution-bbdb.la
-
liborg_gnome_evolution_bbdb_la_SOURCES = bbdb.c bbdb.h gaimbuddies.c
+
liborg_gnome_evolution_bbdb_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
liborg_gnome_evolution_bbdb_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/composer/libcomposer.la \