aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/backup-restore/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@novell.com>2004-12-17 11:15:54 +0800
committerJP Rosevear <jpr@src.gnome.org>2004-12-17 11:15:54 +0800
commitb8cafeb987c18d7bdad2fd45d2e7c4613df04b74 (patch)
treefd39a4c0908f76179a067222dc7bff5a76dc30db /plugins/backup-restore/Makefile.am
parent75d011570d92f39fac17fdb59eb678efba6d6fb4 (diff)
downloadgsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar.gz
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar.bz2
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar.lz
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar.xz
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.tar.zst
gsoc2013-evolution-b8cafeb987c18d7bdad2fd45d2e7c4613df04b74.zip
Imported backup/restore plugin
2004-12-16 JP Rosevear <jpr@novell.com> * Imported backup/restore plugin svn path=/trunk/; revision=28140
Diffstat (limited to 'plugins/backup-restore/Makefile.am')
-rw-r--r--plugins/backup-restore/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/plugins/backup-restore/Makefile.am b/plugins/backup-restore/Makefile.am
new file mode 100644
index 0000000000..3627d1c69a
--- /dev/null
+++ b/plugins/backup-restore/Makefile.am
@@ -0,0 +1,26 @@
+INCLUDES = \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -I$(top_srcdir) \
+ $(SHELL_CFLAGS) \
+ $(E_UTIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-backup-restore.eplug org-gnome-backup-restore.xml
+plugin_LTLIBRARIES = liborg-gnome-backup-restore.la
+
+liborg_gnome_backup_restore_la_SOURCES = backup-restore.c
+liborg_gnome_backup_restore_la_LDFLAGS = -module -avoid-version
+
+privlibexec_PROGRAMS = backup
+backup_SOURCES = backup.c
+backup_LDADD = $(SHELL_LIBS)
+
+EXTRA_DIST = \
+ org-gnome-backup-restore.eplug.in \
+ org-gnome-backup-restore.xml \ No newline at end of file