aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/attachment-reminder/Makefile.am
diff options
context:
space:
mode:
authorBharath Acharya <abharath@novell.com>2008-08-12 12:19:31 +0800
committerBharath Acharya <abharath@src.gnome.org>2008-08-12 12:19:31 +0800
commite860673f10fd166bb28c78f0535b0eac635f4aa9 (patch)
tree5d33e5ac26399305580da76a0824aeb25b55b284 /plugins/attachment-reminder/Makefile.am
parentf5c50178484c5b2fda3170ea66dc50244fcbeb56 (diff)
downloadgsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar.gz
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar.bz2
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar.lz
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar.xz
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.tar.zst
gsoc2013-evolution-e860673f10fd166bb28c78f0535b0eac635f4aa9.zip
Have a check for OS_WIN32 and handle the schema data differently. make
2008-08-12 Bharath Acharya <abharath@novell.com> * Makefile.am: Have a check for OS_WIN32 and handle the schema * data differently. make install error on win32. svn path=/trunk/; revision=35961
Diffstat (limited to 'plugins/attachment-reminder/Makefile.am')
-rw-r--r--plugins/attachment-reminder/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/plugins/attachment-reminder/Makefile.am b/plugins/attachment-reminder/Makefile.am
index d1d0ca90ee..d6e9fb8809 100644
--- a/plugins/attachment-reminder/Makefile.am
+++ b/plugins/attachment-reminder/Makefile.am
@@ -32,12 +32,25 @@ schema_DATA = $(schema_in_files:.schemas.in=.schemas)
@INTLTOOL_SCHEMAS_RULE@
+if OS_WIN32
install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
- done \
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ (echo set GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE); \
+ echo $(GCONFTOOL) --makefile-install-rule $$p) >_temp.bat; \
+ cmd /c _temp.bat; \
+ rm _temp.bat; \
+ done \
fi
+else
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
+ $(GCONFTOOL) --makefile-install-rule $$p; \
+ done \
+ fi
+endif
EXTRA_DIST = org-gnome-evolution-attachment-reminder.eplug.xml \
org-gnome-attachment-reminder.error.xml \