aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/attachment-reminder/Makefile.am
diff options
context:
space:
mode:
authorH.Habighorst <h.habighorst@googlemail.com>2009-10-01 11:37:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-10-01 11:37:50 +0800
commitf62728b55e201ea92e682e07b3253ce4fb42d5af (patch)
tree2083db9702cd5068e7fc4471c47086071e366015 /plugins/attachment-reminder/Makefile.am
parentda3ae4fd5fa723abc4574d0459c761e76abba080 (diff)
downloadgsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.gz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.bz2
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.lz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.xz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.zst
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.zip
Bug 596848 - Use per-target CPPFLAGS in automake files
Diffstat (limited to 'plugins/attachment-reminder/Makefile.am')
-rw-r--r--plugins/attachment-reminder/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/plugins/attachment-reminder/Makefile.am b/plugins/attachment-reminder/Makefile.am
index 94e433795f..1db3b79dad 100644
--- a/plugins/attachment-reminder/Makefile.am
+++ b/plugins/attachment-reminder/Makefile.am
@@ -1,16 +1,6 @@
-AM_CPPFLAGS = \
- -I$(top_builddir)/composer \
- -I$(top_srcdir) \
- -I$(top_srcdir)/widgets \
- $(GNOME_PLATFORM_CFLAGS) \
- $(EVOLUTION_MAIL_CFLAGS) \
- -DEVOLUTION_PLUGINDIR="\"$(plugindir)\""
-
@EVO_PLUGIN_RULE@
-error_DATA = \
- org-gnome-attachment-reminder.error
-
+error_DATA = org-gnome-attachment-reminder.error
errordir = $(privdatadir)/errors
@@ -20,8 +10,19 @@ plugin_DATA = \
plugin_LTLIBRARIES = liborg-gnome-evolution-attachment-reminder.la
+liborg_gnome_evolution_attachment_reminder_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_builddir)/composer \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_PLUGINDIR="\"$(plugindir)\""
+
liborg_gnome_evolution_attachment_reminder_la_SOURCES = attachment-reminder.c
+
liborg_gnome_evolution_attachment_reminder_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
liborg_gnome_evolution_attachment_reminder_la_LIBADD = \
$(top_builddir)/composer/libcomposer.la \
$(top_builddir)/shell/libeshell.la \