aboutsummaryrefslogtreecommitdiffstats
path: root/notes/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@src.gnome.org>2000-06-07 06:34:12 +0800
committerAnders Carlsson <andersca@src.gnome.org>2000-06-07 06:34:12 +0800
commitff31a1c535578b75c986e555026764dbc51e359d (patch)
tree6e6a8fad4af5370f4b45f874e9360b69013e9af4 /notes/Makefile.am
parentc219c79496fca669af1ae093a660a1ce4d81a682 (diff)
downloadgsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar.gz
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar.bz2
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar.lz
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar.xz
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.tar.zst
gsoc2013-evolution-ff31a1c535578b75c986e555026764dbc51e359d.zip
Stuff
svn path=/trunk/; revision=3447
Diffstat (limited to 'notes/Makefile.am')
-rw-r--r--notes/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/notes/Makefile.am b/notes/Makefile.am
new file mode 100644
index 0000000000..c24c2590ce
--- /dev/null
+++ b/notes/Makefile.am
@@ -0,0 +1,58 @@
+bin_PROGRAMS = evolution-notes
+
+noinst_PROGRAMS = notes-test
+
+INCLUDES = \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir)/widgets/e-text \
+ $(BONOBO_HTML_GNOME_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-notes\"
+
+# FIXME We should make a libeshell library instead of this gross hack.
+SHELL_OBJS = \
+ $(top_builddir)/shell/Evolution-common.o \
+ $(top_builddir)/shell/Evolution-stubs.o \
+ $(top_builddir)/shell/Evolution-skels.o \
+ $(top_builddir)/shell/evolution-shell-component.o \
+ $(top_builddir)/shell/evolution-storage.o
+
+evolution_notes_SOURCES = \
+ component-factory.c \
+ main.c \
+ notes.c
+
+notes_test_SOURCES = \
+ e-bevel-button.c \
+ e-bevel-button.h \
+ e-bevel-button-util.c \
+ e-bevel-button-util.h \
+ e-note.c \
+ e-note.h \
+ test-notes.c
+
+OAF_FILES = evolution-notes.oafinfo
+
+if USING_OAF
+oafdir = $(datadir)/oaf
+oaf_DATA = $(OAF_FILES)
+endif
+
+notes_test_LDADD = \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ ../e-util/libeutil.la \
+ $(BONOBO_HTML_GNOME_LIBS)
+
+evolution_notes_LDADD = \
+ ../e-util/libeutil.la \
+ $(SHELL_OBJS) \
+ $(BONOBO_HTML_GNOME_LIBS)
+
+
+
+