aboutsummaryrefslogtreecommitdiffstats
path: root/modules/windows-sens/Makefile.am
diff options
context:
space:
mode:
authorFridrich Strba <fridrich.strba@bluewin.ch>2010-03-24 01:54:37 +0800
committerFridrich Strba <fridrich.strba@bluewin.ch>2010-03-24 01:54:37 +0800
commit8a8e79622eadb6c2577e77f5a3d7655e743dd219 (patch)
treeda04e983c4819d63310cf89a54e829dc5e3f0f86 /modules/windows-sens/Makefile.am
parentaf5bfa98a8c7a11a345e2b7403b792ed970d5cef (diff)
downloadgsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.gz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.bz2
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.lz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.xz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.zst
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.zip
[win32] Implement network status detection
The implementation is done using System Event Notification Service by implementing ConnectionMade ConnectionMadeNoQOCInfo and ConnectionLost methods of ISensNetwork interface. Introduces C++ dependency for Windows port only
Diffstat (limited to 'modules/windows-sens/Makefile.am')
-rw-r--r--modules/windows-sens/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/windows-sens/Makefile.am b/modules/windows-sens/Makefile.am
new file mode 100644
index 0000000000..29b027fcf3
--- /dev/null
+++ b/modules/windows-sens/Makefile.am
@@ -0,0 +1,19 @@
+module_LTLIBRARIES = libevolution-module-windows-sens.la
+
+libevolution_module_windows_sens_la_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-windows-sens\" \
+ $(GNOME_PLATFORM_CFLAGS)
+
+libevolution_module_windows_sens_la_SOURCES = \
+ evolution-windows-sens.cxx
+
+libevolution_module_windows_sens_la_LIBADD = \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS) \
+ $(SENS_LIBS)
+
+libevolution_module_windows_sens_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk