aboutsummaryrefslogtreecommitdiffstats
path: root/modules/web-inspector/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /modules/web-inspector/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'modules/web-inspector/Makefile.am')
-rw-r--r--modules/web-inspector/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/modules/web-inspector/Makefile.am b/modules/web-inspector/Makefile.am
index 985e483725..43615d549b 100644
--- a/modules/web-inspector/Makefile.am
+++ b/modules/web-inspector/Makefile.am
@@ -1,23 +1,24 @@
module_LTLIBRARIES = module-web-inspector.la
-module_web_inspector_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -I$(top_srcdir) \
- -DG_LOG_DOMAIN=\"evolution-web-inspector\" \
- $(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS) \
- $(GTKHTML_CFLAGS)
+module_web_inspector_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-web-inspector\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
module_web_inspector_la_SOURCES = \
evolution-web-inspector.c
module_web_inspector_la_LIBADD = \
- $(top_builddir)/e-util/libevolution-util.la \
- $(EVOLUTION_DATA_SERVER_LIBS) \
- $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libevolution-util.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
$(GTKHTML_LIBS)
module_web_inspector_la_LDFLAGS = \
- -module -avoid-version $(NO_UNDEFINED)
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
-include $(top_srcdir)/git.mk