aboutsummaryrefslogtreecommitdiffstats
path: root/modules/mail-config/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-02-17 23:47:06 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:42 +0800
commit48e680cdf39ab5754b000229f8ded1a8eeebf437 (patch)
tree063b7412f13d2248612b1872a0cf4ffbc119631f /modules/mail-config/Makefile.am
parent209e47b133349dc29c3eb68b9d4b5ac3465e0a0d (diff)
downloadgsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar.gz
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar.bz2
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar.lz
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar.xz
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.tar.zst
gsoc2013-evolution-48e680cdf39ab5754b000229f8ded1a8eeebf437.zip
Add 'mail-config' module.
This breaks a good chunk of logic out of EMAccountEditor and hopefully makes it less brittle. Because honestly, every time I fix one thing in EMAccountEditor it breaks three other things. It's unmaintainable.
Diffstat (limited to 'modules/mail-config/Makefile.am')
-rw-r--r--modules/mail-config/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/modules/mail-config/Makefile.am b/modules/mail-config/Makefile.am
new file mode 100644
index 0000000000..1efd510c42
--- /dev/null
+++ b/modules/mail-config/Makefile.am
@@ -0,0 +1,39 @@
+NULL =
+
+module_LTLIBRARIES = module-mail-config.la
+
+module_mail_config_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-mail-config\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(NULL)
+
+module_mail_config_la_SOURCES = \
+ evolution-mail-config.c \
+ e-mail-config-local-accounts.c \
+ e-mail-config-remote-accounts.c \
+ e-mail-config-sendmail-backend.c \
+ e-mail-config-sendmail-backend.h \
+ e-mail-config-smtp-backend.c \
+ e-mail-config-smtp-backend.h \
+ e-mail-config-google-summary.c \
+ e-mail-config-google-summary.h \
+ e-mail-config-yahoo-summary.c \
+ e-mail-config-yahoo-summary.h \
+ $(NULL)
+
+module_mail_config_la_LIBADD = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/libemail-engine/libemail-engine.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(NULL)
+
+module_mail_config_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk