aboutsummaryrefslogtreecommitdiffstats
path: root/modules/connman/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2010-03-24 18:24:56 +0800
committerMichael Meeks <michael.meeks@novell.com>2010-04-07 19:22:09 +0800
commit6416086f149ee7d3f267bd67d3019ef26122c07a (patch)
treec090e390a59a5d0e062271364129f2d2595263bb /modules/connman/Makefile.am
parent6823af7d0b96a72a27159836b533e5d22130b7f2 (diff)
downloadgsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.gz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.bz2
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.lz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.xz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.zst
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.zip
Add ConnMan support (words fail me ...)
Conflicts: configure.ac modules/Makefile.am
Diffstat (limited to 'modules/connman/Makefile.am')
-rw-r--r--modules/connman/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/connman/Makefile.am b/modules/connman/Makefile.am
new file mode 100644
index 0000000000..63822262c4
--- /dev/null
+++ b/modules/connman/Makefile.am
@@ -0,0 +1,22 @@
+module_LTLIBRARIES = libevolution-module-connman.la
+
+libevolution_module_connman_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-connman\" \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS)
+
+libevolution_module_connman_la_SOURCES = \
+ evolution-connman.c
+
+libevolution_module_connman_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS) \
+ $(DBUS_GLIB_LIBS)
+
+libevolution_module_connman_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk