aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-weather/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /modules/cal-config-weather/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'modules/cal-config-weather/Makefile.am')
-rw-r--r--modules/cal-config-weather/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/modules/cal-config-weather/Makefile.am b/modules/cal-config-weather/Makefile.am
index 53d88247bc..f1a22f0cd9 100644
--- a/modules/cal-config-weather/Makefile.am
+++ b/modules/cal-config-weather/Makefile.am
@@ -7,7 +7,8 @@ module_cal_config_weather_la_CPPFLAGS = \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
$(GTKHTML_CFLAGS) \
- $(GWEATHER_CFLAGS)
+ $(GWEATHER_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
module_cal_config_weather_la_SOURCES = \
evolution-cal-config-weather.c \
@@ -22,6 +23,6 @@ module_cal_config_weather_la_LIBADD = \
$(GWEATHER_LIBS)
module_cal_config_weather_la_LDFLAGS = \
- -module -avoid-version $(NO_UNDEFINED)
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
-include $(top_srcdir)/git.mk