aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorFridrich Strba <fridrich.strba@bluewin.ch>2010-03-24 01:54:37 +0800
committerFridrich Strba <fridrich.strba@bluewin.ch>2010-03-24 01:54:37 +0800
commit8a8e79622eadb6c2577e77f5a3d7655e743dd219 (patch)
treeda04e983c4819d63310cf89a54e829dc5e3f0f86 /modules/Makefile.am
parentaf5bfa98a8c7a11a345e2b7403b792ed970d5cef (diff)
downloadgsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.gz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.bz2
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.lz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.xz
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.tar.zst
gsoc2013-evolution-8a8e79622eadb6c2577e77f5a3d7655e743dd219.zip
[win32] Implement network status detection
The implementation is done using System Event Notification Service by implementing ConnectionMade ConnectionMadeNoQOCInfo and ConnectionLost methods of ISensNetwork interface. Introduces C++ dependency for Windows port only
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 0b6ccf22ec..653d1b69c6 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -10,6 +10,10 @@ if ENABLE_NETWORK_MANAGER
NETWORK_MANAGER_DIR = network-manager
endif
+if ENABLE_WINDOWS_SENS
+WINDOWS_SENS_DIR = windows-sens
+endif
+
SUBDIRS = \
addressbook \
calendar \
@@ -17,6 +21,7 @@ SUBDIRS = \
plugin-lib \
$(MONO_DIR) \
$(PYTHON_DIR) \
- $(NETWORK_MANAGER_DIR)
+ $(NETWORK_MANAGER_DIR) \
+ $(WINDOWS_SENS_DIR)
-include $(top_srcdir)/git.mk