aboutsummaryrefslogtreecommitdiffstats
path: root/mail/importers/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:39:10 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:39:10 +0800
commit24d00dba858a3a5c87092a3ac6c837c456cf4ca8 (patch)
tree3f88196ae086e6a0fc1bcbcf81a398a588b1fc68 /mail/importers/Makefile.am
parent29fb1732b2f2d50bc6bba812394621dc5df27fda (diff)
downloadgsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.gz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.bz2
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.lz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.xz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.zst
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.zip
Split the ORBit IDL compilation rules to work properly with parallel
* importers/Makefile.am: Split the ORBit IDL compilation rules to work properly with parallel makes. (BUILT_SOURCES): Add this. (CLEANFILES): Add this. * Makefile.am: Split the ORBit IDL compilation rules to work properly with parallel makes. (BUILT_SOURCES): Add $(IDL_GENERATED) here. (CLEANFILES): Remove from here. svn path=/trunk/; revision=19874
Diffstat (limited to 'mail/importers/Makefile.am')
-rw-r--r--mail/importers/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/mail/importers/Makefile.am b/mail/importers/Makefile.am
index 3512930506..87f9f6657d 100644
--- a/mail/importers/Makefile.am
+++ b/mail/importers/Makefile.am
@@ -27,14 +27,17 @@ libmbox_la_LDFLAGS = -avoid-version -module
IDLS = \
$(top_srcdir)/mail/Mailer.idl
-MAIL_GENERATED = \
- Mailer.h \
+MAIL_GENERATED_H = \
+ Mailer.h
+MAIL_GENERATED_C = \
Mailer-common.c \
Mailer-skels.c \
Mailer-stubs.c
+MAIL_GENERATED = $(MAIL_GENERATED_C) $(MAIL_GENERATED_H)
-$(MAIL_GENERATED): $(IDLS)
+$(MAIL_GENERATED_H): $(IDLS)
$(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(top_srcdir)/mail/Mailer.idl
+$(MAIL_GENERATED_C): $(MAIL_GENERATED_H)
libevolution_netscape_importer_la_SOURCES = \
$(MAIL_GENERATED) \
@@ -96,6 +99,11 @@ server_DATA = $(server_in_files:.server.in.in=.server)
%.server.in: %.server.in.in
sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+
EXTRA_DIST = $(server_in_files) $(server_DATA)
+BUILT_SOURCES = $(MAIL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
+
@INTLTOOL_SERVER_RULE@