aboutsummaryrefslogtreecommitdiffstats
path: root/mail/importers/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2003-02-05 12:25:40 +0800
committerMichael Zucci <zucchi@src.gnome.org>2003-02-05 12:25:40 +0800
commit2dd6f4d7deacc0410411b47d77c1ba60cc927af0 (patch)
treee55e7089f8209575c7eb38921a12dc2fd4169b0a /mail/importers/Makefile.am
parent5c82a6632996c2062de16486eb6c91476dc63946 (diff)
downloadgsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar.gz
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar.bz2
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar.lz
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar.xz
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.tar.zst
gsoc2013-evolution-2dd6f4d7deacc0410411b47d77c1ba60cc927af0.zip
update from ../../importers/. (main): Removed.
2003-02-05 Not Zed <NotZed@Ximian.com> * importers/netscape-importer.c: update from ../../importers/. (main): Removed. (mail_importer_module_init): Setup module init fn. (factory_fn): api changes. (is_dir_empty): deprecated changes, and clean up logic. (importer_cb): pulse progress bar, use idle function for processing next item. (import_next): Remove link before recursing, also fix memleak, and api changes. (netscape_import_file): dont release importer. (*): gconf'ify * importers/elm-importer.c (elm_factory_fn): Track the evolution_intelligent_importer, so we can unref it when done. (*): gconf'ify. * importers/pine-importer.c (parse_line): use gobject stuff rather than gtkobject. (import_addressfile): close down 'properly' when finished. (importer_timeout_fn): Do most processing decisions here, either from a timeout or idle function. This prevents us getting 1 stack frame per message and per folder. Close down properly also. (importer_cb): Add a timeout, ignore the callback, or add an idle function to process the next item. (pine_import_file): dont release the importer if we can't load it, its released elsewhere, i think. (import_addressfile): step the progress bar as we go. (factory_fn): Track the evolution_intelligent_importer, so we can unref when done. (*): gconf'ify 2003-01-31 Not Zed <NotZed@Ximian.com> * importers/elm-importer.c (elm_can_import): g_file_exists -> lstat, and g_build_filename api changes. * importers/pine-importer.c: moved from ../../importers/pine-importer.c (factory_fn): oaf->bonobo_activation (mail_importer_module_init): setup factory. (main): Removed. (*): REemove bonobo config stuff. (factory_fn): destroy signal -> weak ref. (pine_destroy_cb): Fix signature for weak ref notify. (import_addressfile): use new glib filename stuff. (import_addressbook): same. (pine_can_import): and here. (import_next): and here. (scan_dir): and here (pine_create_structure): And here. (pine_can_import): g_file_exists -> lstat. (importer_cb): If there are more items, use an idle handler to drop back a few stack frames rather than recursing for each message. (import_next): unlink data from dir_list before recursing, and fix leak. 2003-01-30 Not Zed <NotZed@Ximian.com> * importers/elm-importer.c (elm_destroy_cb): Change for weak ref setup. (elm_factory_fn): destroy -> weak ref. 2003-01-29 Not Zed <NotZed@Ximian.com> * importers/elm-importer.c (importer_cb): Pass processItem off to an idle handler, so we dont blow our stacks. Also update to use progress_bar_pulse(). (import_item_idle): Get the next message here instead. (import_next): Fix a glist leak. Unlink the file before we import it too. And close the dialogue and clean up when we've run out of folders to import. 2003-01-17 Not Zed <NotZed@Ximian.com> * importers/elm-importer.c (elm_create_structure): use/free elmdir rather than double-free maildir. 2003-01-16 Not Zed <NotZed@Ximian.com> * importers/elm-importer.c: update from ../importers/elm-importer.c svn path=/trunk/; revision=19752
Diffstat (limited to 'mail/importers/Makefile.am')
-rw-r--r--mail/importers/Makefile.am70
1 files changed, 68 insertions, 2 deletions
diff --git a/mail/importers/Makefile.am b/mail/importers/Makefile.am
index 7300acb9f2..e9d35224f1 100644
--- a/mail/importers/Makefile.am
+++ b/mail/importers/Makefile.am
@@ -1,6 +1,9 @@
importersdir = $(privlibdir)/evolution-mail-importers
-importers_LTLIBRARIES = liboutlook.la libmbox.la
+importers_LTLIBRARIES = liboutlook.la libmbox.la \
+ libevolution-elm-importer.la \
+ libevolution-pine-importer.la \
+ libevolution-netscape-importer.la
INCLUDES = -I.. \
-I$(srcdir)/.. \
@@ -9,6 +12,9 @@ INCLUDES = -I.. \
-I$(top_builddir)/shell \
-I$(includedir) \
-DG_LOG_DOMAIN=\"evolution-mail-importer\" \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
$(IMPORTERS_CFLAGS)
liboutlook_la_SOURCES = \
@@ -19,9 +25,69 @@ libmbox_la_SOURCES = evolution-mbox-importer.c \
mozilla-status-headers.h
libmbox_la_LDFLAGS = -avoid-version -module
+IDLS = \
+ $(top_srcdir)/mail/Mailer.idl
+
+MAIL_GENERATED = \
+ Mailer.h \
+ Mailer-common.c \
+ Mailer-skels.c \
+ Mailer-stubs.c
+
+$(MAIL_GENERATED): $(IDLS)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(top_srcdir)/mail/Mailer.idl
+
+libevolution_netscape_importer_la_SOURCES = \
+ $(MAIL_GENERATED) \
+ netscape-importer.c
+
+libevolution_netscape_importer_la_LIBADD = \
+ $(top_builddir)/shell/importer/libevolution-importer.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/filter/libfilter.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(IMPORTERS_LIBS)
+
+libevolution_elm_importer_la_SOURCES = \
+ elm-importer.c
+
+libevolution_elm_importer_la_LIBADD = \
+ $(top_builddir)/shell/importer/libevolution-importer.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(IMPORTERS_LIBS)
+
+libevolution_pine_importer_la_SOURCES = \
+ pine-importer.c
+
+libevolution_pine_importer_la_LIBADD = \
+ $(top_builddir)/shell/importer/libevolution-importer.la \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/libversit/libversit.a \
+ $(IMPORTERS_LIBS)
+
+# evolution_gnomecard_importer_SOURCES = \
+# evolution-gnomecard-importer.c
+
+# evolution_gnomecard_importer_LDADD = \
+# $(top_builddir)/shell/importer/libevolution-importer.la \
+# $(top_builddir)/addressbook/backend/ebook/libebook.la \
+# $(top_builddir)/camel/libcamel.la \
+# $(top_builddir)/e-util/libeutil.la \
+# $(top_builddir)/e-util/ename/libename.la \
+# $(top_builddir)/libversit/libversit.a \
+# $(IMPORTERS_LIBS)
+
+
serverdir = $(libdir)/bonobo/servers
server_in_files = GNOME_Evolution_Mail_Mbox_Importer.server.in.in \
- GNOME_Evolution_Mail_Outlook_Importer.server.in.in
+ GNOME_Evolution_Mail_Outlook_Importer.server.in.in \
+ GNOME_Evolution_Mail_Netscape_Intelligent_Importer.server.in.in \
+ GNOME_Evolution_Mail_Elm_Intelligent_Importer.server.in.in \
+ GNOME_Evolution_Mail_Pine_Intelligent_Importer.server.in.in
server_DATA = $(server_in_files:.server.in.in=.server)
%.server.in: %.server.in.in
sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@