aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorMiguel de Icaza <miguel@gnu.org>2000-02-16 01:28:34 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-02-16 01:28:34 +0800
commitd53eea370b1a53cbae519c92fa602d0e7aa5ecc8 (patch)
tree610202886dae8219e74e4e83e344d735c16a6c4a /mail/Makefile.am
parentf9cdc1e00912852e94f454b0de79d613df46c19d (diff)
downloadgsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.gz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.bz2
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.lz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.xz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.zst
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.zip
Add the unicode libraries as well.
2000-02-14 Miguel de Icaza <miguel@gnu.org> * camel/providers/mbox/Makefile.am (libcamelmbox_la_LIBADD): Add the unicode libraries as well. * camel/camel-provider.c (camel_provider_register_as_module): Add error reporting here. Desire to use Solaris increases. Hair loss in the last two hours: 5,400. * camel/providers/mbox/camel-mbox-provider.c (camel_mbox_get_provider): Renamed function. * camel/camel.h: All include files use camel/ now here. * camel/providers/mbox/Makefile.am: Drop all the dynamism from Camel, and make this a standard library. * configure.in: set the UNICODE_LIBS variable here. 2000-02-14 Miguel de Icaza <miguel@gnu.org> * folder-browser.c (folder_browser_load_folder): New routine, loads a camel folder. (folder_browser_set_uri): redo. * session.c: new file. Implements SessionStores to keep track of a Session/Store tuple. svn path=/trunk/; revision=1783
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 36c61e427d..8132951901 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,10 +1,13 @@
bin_PROGRAMS = evolution-mail test-mail
+providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
+
INCLUDES = \
-DEVOLUTION_VERSION=\""$(VERSION)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/widgets/e-text \
$(BONOBO_HTML_GNOME_CFLAGS)
@@ -27,7 +30,9 @@ evolution_mail_SOURCES = \
mail-display.c \
main.c \
message-list.c \
- message-list.h
+ message-list.h \
+ session.c \
+ session.h
evolution_mail_LDADD = \
../widgets/e-table/libetable.a \