aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-04-08 04:07:32 +0800
committerDan Winship <danw@src.gnome.org>2000-04-08 04:07:32 +0800
commit2b55a1e90c9554540413d2e74716e9c60b3710ce (patch)
tree13913ecb8d692d44fa8aa2b5922b39108e76bc23 /mail/Makefile.am
parent5f93b830400c342ce0a20362df8d744120541478 (diff)
downloadgsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar.gz
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar.bz2
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar.lz
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar.xz
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.tar.zst
gsoc2013-evolution-2b55a1e90c9554540413d2e74716e9c60b3710ce.zip
new file, for toolbar/menu callbacks (fetch_mail): fetch mail. Doesn't do
* mail-ops.c: new file, for toolbar/menu callbacks (fetch_mail): fetch mail. Doesn't do mbox locking. Many kludges. * folder-browser-factory.c (control_activate): use new fetch_mail function as the callback for the "New mail" icon. Rename check_cb to random_cb. * Makefile.am: don't build test-sources since the version in CVS doesn't do much and once I've fixed it it won't be a separate program. Add mail-ops.[ch]. svn path=/trunk/; revision=2330
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 707d514af3..189faf1dcd 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,4 +1,4 @@
-bin_PROGRAMS = evolution-mail test-mail test-sources
+bin_PROGRAMS = evolution-mail test-mail
providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
@@ -33,6 +33,8 @@ evolution_mail_SOURCES = \
html-stream.h \
mail-display.h \
mail-display.c \
+ mail-ops.c \
+ mail-ops.h \
main.c \
message-list.c \
message-list.h \
@@ -60,12 +62,6 @@ test_mail_LDADD = \
$(BONOBO_HTML_GNOME_LIBS)
-test_sources_SOURCES = \
- mail-sources.c
-
-test_sources_LDADD = \
- $(BONOBO_HTML_GNOME_LIBS)
-
gnorbadir = $(sysconfdir)/CORBA/servers
gnorba_DATA = evolution-mail.gnorba