aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@arcavia.com>2000-07-29 14:04:24 +0800
committerJP Rosevear <jpr@src.gnome.org>2000-07-29 14:04:24 +0800
commit121d056d45b9766532ba9b7ec3f687c04582194f (patch)
tree75859f4896fce1e883e5c1f5440097092db0f7ad /mail/Makefile.am
parentf34353458d545d679e9daebb22ade4f1f02c8e00 (diff)
downloadgsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar.gz
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar.bz2
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar.lz
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar.xz
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.tar.zst
gsoc2013-evolution-121d056d45b9766532ba9b7ec3f687c04582194f.zip
New function to create composer with sig file set.
2000-07-28 JP Rosevear <jpr@arcavia.com> * e-msg-composer.c (e_msg_composer_new_with_sig_file): New function to create composer with sig file set. (e_msg_composer_get_sig_file): New function to get sig file (e_msg_composer_set_sig_file): New function to set sig file 2000-07-29 JP Rosevear <jpr@arcavia.com> * mail-format.c (mail_generate_reply): Use new mail config stuff * component-factory.c (create_imap_storage): Use new mail config stuff (create_news_storage): ditto * evolution-mail.schemas: Gconf schema for evolution mail * mail-config-druid.glade: Gladification of config druid * mail-config.h: New header with config structs. * mail-config.c: Rewrite of GUI configuration tools to use new config structs. Stores multiple identities and sources now. Still only uses the first one found. (mail_config_fetch): Returns MailConfig struct to caller for configuration queries. (mail_config): Renamed function to show mail config dialog. (mail_config_druid): Renamed function to show mail config druid. * mail-ops.c (create_msg_composer): Use e_msg_composer_new_with_sig_file and new config stuff (check_configured): Use new config stuff (fetch_mail): ditto (composer_send_cb): ditto svn path=/trunk/; revision=4413
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 05f3260c2f..ab08d1315f 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -105,8 +105,12 @@ gnorba_DATA = $(GOAD_FILES)
endif
gladedir = $(datadir)/evolution/glade
-glade_DATA = \
- mail-config.glade
+glade_DATA = mail-config.glade mail-config-druid.glade
+
+schemadir = $(sysconfdir)/gconf/schemas
+schema_DATA = evolution-mail.schemas
+
+iconsdir = $(datadir)/images/evolution
$(EVOLUTION_MAIL_CORBA_GENERATED): Mail.idl
$(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Mail.idl