aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authornobody <nobody@localhost>2000-07-06 12:58:12 +0800
committernobody <nobody@localhost>2000-07-06 12:58:12 +0800
commit5e7d23492183857392e728cec05521e320ba1b29 (patch)
tree4ba00fa4856e39912c9a54ecba72de80d51d2418 /mail/Makefile.am
parent04f148f617112009091abd18b16463033dd322d0 (diff)
downloadgsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar.gz
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar.bz2
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar.lz
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar.xz
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.tar.zst
gsoc2013-evolution-5e7d23492183857392e728cec05521e320ba1b29.zip
This commit was manufactured by cvs2svn to create tag 'GTKHTML_0_5'.GTKHTML_0_5
svn path=/tags/GTKHTML_0_5/; revision=3912
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am118
1 files changed, 0 insertions, 118 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
deleted file mode 100644
index dce2a11a03..0000000000
--- a/mail/Makefile.am
+++ /dev/null
@@ -1,118 +0,0 @@
-bin_PROGRAMS = evolution-mail
-
-noinst_PROGRAMS = test-mail test-thread
-
-providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
-
-INCLUDES = \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir) \
- -I$(top_srcdir)/camel \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- $(BONOBO_HTML_GNOME_CFLAGS) \
- $(GNOME_VFS_CFLAGS) \
- -DEVOLUTION_VERSION=\""$(VERSION)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
- -DG_LOG_DOMAIN=\"evolution-mail\" \
- $(THREADS_CFLAGS)
-
-EVOLUTION_MAIL_CORBA_GENERATED = \
- Mail.h \
- Mail-common.c \
- Mail-skels.c \
- Mail-stubs.c
-
-# FIXME Is there any way around having to do this?
-CAMEL_OBJS_EXTRA = \
- $(top_builddir)/camel/providers/vee/libcamelvee.la
-
-evolution_mail_SOURCES = \
- $(EVOLUTION_MAIL_CORBA_GENERATED) \
- component-factory.c \
- component-factory.h \
- folder-browser.c \
- folder-browser.h \
- folder-browser-factory.c \
- mail-config.c \
- mail-display.c \
- mail-display.h \
- mail-format.c \
- mail-identify.c \
- mail-ops.c \
- mail-threads.c \
- mail-threads.h \
- mail-types.h \
- main.c \
- message-list.c \
- message-list.h \
- session.c \
- mail.h
-
-
-evolution_mail_LDADD = \
- $(top_builddir)/shell/libeshell.a \
- $(top_builddir)/composer/libcomposer.la \
- $(top_builddir)/widgets/e-paned/libepaned.a \
- $(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/widgets/e-table/libetable.a \
- $(top_builddir)/widgets/e-text/libetext.a \
- $(CAMEL_OBJS_EXTRA) \
- $(top_builddir)/camel/libcamel.la \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/libibex/libibex.la \
- $(top_builddir)/filter/libfilter.la \
- $(BONOBO_VFS_GNOME_LIBS) \
- $(GTKHTML_LIBS) \
- $(THREADS_LIBS) \
- $(UNICODE_LIBS)
-
-test_mail_SOURCES = \
- test-mail.c
-
-test_mail_LDADD = \
- $(BONOBO_HTML_GNOME_LIBS)
-
-test_thread_SOURCES = \
- mail-threads.c \
- mail-threads.h \
- test-thread.c
-
-test_thread_LDADD = \
- $(BONOBO_HTML_GNOME_LIBS) \
- $(THREADS_LIBS)
-
-test_thread_CFLAGS = -g $(THREADS_CFLAGS)
-
-GOAD_FILES = evolution-mail.gnorba
-OAF_FILES = evolution-mail.oafinfo
-
-if USING_OAF
-oafdir = $(datadir)/oaf
-oaf_DATA = $(OAF_FILES)
-else
-gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = $(GOAD_FILES)
-endif
-
-$(EVOLUTION_MAIL_CORBA_GENERATED): Mail.idl
- $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Mail.idl
-
-EXTRA_DIST = Mail.idl $(GOAD_FILES) $(OAF_FILES)
-
-if ENABLE_PURIFY
-PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-
-all-local: evolution-mail.pure
-
-evolution-mail.pure: evolution-mail
- @rm -f evolution-mail.pure
- $(PLINK) $(evolution_mail_LDFLAGS) $(evolution_mail_OBJECTS) $(evolution_mail_LDADD) $(LIBS)
-
-endif
-