aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-08-02 10:56:48 +0800
committerDan Winship <danw@src.gnome.org>2000-08-02 10:56:48 +0800
commit324b1e8675ed32dcdc051a2fd916158bd02a9893 (patch)
tree341c0f634e335e1deba13131ffaac4545f6c43e3 /mail/Makefile.am
parentfad59bb3a344526f343b8e28a8d28059e81a42a9 (diff)
downloadgsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar.gz
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar.bz2
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar.lz
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar.xz
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.tar.zst
gsoc2013-evolution-324b1e8675ed32dcdc051a2fd916158bd02a9893.zip
New code to spawn off GPG/PGP to do stuff. Currently only deals with
* mail-crypto.c: New code to spawn off GPG/PGP to do stuff. Currently only deals with decryption. From Nathan Thompson-Amato <ndt@jps.net>, with bunches of changes from me. * session.c (mail_request_dialog): Expose the password dialog to the rest of the app (for use by the GPG/PGP code). * mail-format.c (handle_text_plain): Handle special inline data types. (Currently uuencoding, BinHex, and PGP encryption.) This is not the best way to deal with it, but it works for now. (try_inline_pgp): Convert an inline PGP-encrypted message into a multipart/encrypted part. (try_inline_binhex): Convert an inline BinHex attachment into an application/mac-binhex40 part (which we currently don't deal with...) (try_uudecoding): Convert a uuencoded attachment to an application/octet-stream part. (handle_multipart_encrypted): Deal with RFC2015 MIME-encoded PGP encrypted messages. (From ndt.) * mail-display.c (mail_text_write, mail_error_write): New utility functions. * Makefile.am (evolution_mail_SOURCES): add mail-crypto.c svn path=/trunk/; revision=4466
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index c5752ac822..7204c237dd 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -41,6 +41,7 @@ evolution_mail_SOURCES = \
folder-browser.h \
folder-browser-factory.c \
mail-config.c \
+ mail-crypto.c \
mail-display.c \
mail-display.h \
mail-format.c \