aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorSam Creasey <sammy@oh.verio.com>2001-07-03 10:56:39 +0800
committerSam Creasy <sammy@src.gnome.org>2001-07-03 10:56:39 +0800
commite1e2d6393df2a7e1af08a18330fe65c49d81d9c9 (patch)
treeef69ef8a56d351818f72533a6ee6b71d244589a6 /mail/Makefile.am
parentfd6ad06df5c3cf3928f9361d566aaaaffe498d2d (diff)
downloadgsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar.gz
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar.bz2
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar.lz
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar.xz
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.tar.zst
gsoc2013-evolution-e1e2d6393df2a7e1af08a18330fe65c49d81d9c9.zip
Added an MailAccountEditorNews, for NNTP configuratuion. Based on
2001-07-02 Sam Creasey <sammy@oh.verio.com> * mail-account-editor-news.c: Added an MailAccountEditorNews, for NNTP configuratuion. Based on MailAccountEditor, but stripped. * Makefile.am: added mail-account-editor-news.c and mail-account-editor-news.h to SOURCES if ENABLE_NNTP is defined. * mail-accounts.c (load_news): Moved this function, and fixed some slight brokenness. (news_edit): Added functional code using MailAccountEditorNews (news_add): Added functional code using news_edit after allocation. * mail-config.glade: news_editor_window widget added. Used by MailAccountEditorNews. * mail-display.c (save_data_cb): Store the pathname used when saving messages so that the next save box will default to the previous path. * message-browser.c (message_browser_new): add signal handler for size_allocate on the message browser. Thus new windows are size as they were last allocated. (message_browser_size_allocate_cb): handler to store allocations. * message-list.c (message_list_setup_etree): connect to the info_changed signals for the state of the message_list->tree. Save the folder state to disk, so that when additional message_lists are created, they are consistant. e.g. the next buttons do the same thing in the browser, and in the message viewer after changing sorting options. * subscribe-dialog.c (build_tree): freeze sc->folder model while building the tree. Not doing so takes a very long time over 40000 newsgroups. svn path=/trunk/; revision=10719
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 76566dea47..4fb0ddcf50 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -35,8 +35,16 @@ EVOLUTION_MAIL_CORBA_GENERATED = \
Mail-skels.c \
Mail-stubs.c
+if ENABLE_NNTP
+EVOLUTION_MAIL_NNTP = \
+ mail-account-editor-news.c \
+ mail-account-editor-news.h
+endif
+
+
evolution_mail_SOURCES = \
$(EVOLUTION_MAIL_CORBA_GENERATED) \
+ $(EVOLUTION_MAIL_NNTP) \
component-factory.c \
component-factory.h \
e-searching-tokenizer.c \