aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-06-13 12:53:48 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-06-13 12:53:48 +0800
commit7ba831860dfa5e96d9d19a0b5907d5237e60596a (patch)
tree50cc600ccb20b0f5204d559e3ab31f189ad718c8 /mail/Makefile.am
parentcc240fcffe0ecf84e83428b2f05bc08259396ffe (diff)
downloadgsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar.gz
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar.bz2
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar.lz
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar.xz
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.tar.zst
gsoc2013-evolution-7ba831860dfa5e96d9d19a0b5907d5237e60596a.zip
Build a `libeshell.a' library in `shell/' so that we don't need to
link to the shell's object files directly from the components anymore. (That was really gross.) svn path=/trunk/; revision=3546
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 81724fc04e..51c7aa3150 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -28,14 +28,6 @@ EVOLUTION_MAIL_CORBA_GENERATED = \
Mail-skels.c \
Mail-stubs.c
-# FIXME We should make a libeshell library instead of this gross hack.
-SHELL_OBJS = \
- $(top_builddir)/shell/Evolution-common.o \
- $(top_builddir)/shell/Evolution-stubs.o \
- $(top_builddir)/shell/Evolution-skels.o \
- $(top_builddir)/shell/evolution-shell-component.o \
- $(top_builddir)/shell/evolution-storage.o
-
# FIXME Is there any way around having to do this?
CAMEL_OBJS_EXTRA = \
$(top_builddir)/camel/providers/vee/libcamelvee.la
@@ -63,17 +55,17 @@ evolution_mail_SOURCES = \
evolution_mail_LDADD = \
- $(SHELL_OBJS) \
- ../composer/libcomposer.la \
+ $(top_builddir)/shell/libeshell.a \
+ $(top_builddir)/composer/libcomposer.la \
$(top_builddir)/widgets/e-paned/libepaned.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
- ../widgets/e-table/libetable.a \
- ../widgets/e-text/libetext.a \
+ $(top_builddir)/widgets/e-table/libetable.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
$(CAMEL_OBJS_EXTRA) \
- ../camel/libcamel.la \
- ../e-util/libeutil.la \
- ../libibex/libibex.la \
- ../filter/libfilter.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(top_builddir)/filter/libfilter.la \
$(BONOBO_HTML_GNOME_LIBS) \
$(UNICODE_LIBS)