aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2008-10-14 01:57:46 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-10-14 01:57:46 +0800
commit79aa45cfed7e87150de85869795ef0dd3be06db0 (patch)
tree422b9e6c3840747ffb243d596d4459514ec3a457 /mail/Makefile.am
parent1bed00795bf092ad6e9e076eccf7cc2a8c20cb27 (diff)
downloadgsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar.gz
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar.bz2
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar.lz
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar.xz
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.tar.zst
gsoc2013-evolution-79aa45cfed7e87150de85869795ef0dd3be06db0.zip
Progress update:
- Calendar is kind of a mess at the moment. Doesn't compile. - Roughed in the Mail module, including all the actions. That _does_ compile. Runs, even. svn path=/branches/kill-bonobo/; revision=36611
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am349
1 files changed, 174 insertions, 175 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 23778d569c..e029968a0f 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = default importers
+#SUBDIRS = default importers
mailincludedir = $(privincludedir)/mail
@@ -31,159 +31,159 @@ INCLUDES = \
-DPREFIX=\""$(prefix)"\" \
-DG_LOG_DOMAIN=\"evolution-mail\"
-component_LTLIBRARIES = libevolution-mail.la
-
-# Mail.idl
-MAIL_IDL = Evolution-Mail.idl
-MAIL_IDL_GENERATED_H = \
- Evolution-Mail.h
-MAIL_IDL_GENERATED_C = \
- Evolution-Mail-common.c \
- Evolution-Mail-skels.c \
- Evolution-Mail-stubs.c
-MAIL_IDL_GENERATED = $(MAIL_IDL_GENERATED_C) $(MAIL_IDL_GENERATED_H)
-
-$(MAIL_IDL_GENERATED_H): $(MAIL_IDL)
- $(ORBIT_IDL) -I $(top_srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $^
-$(MAIL_IDL_GENERATED_C): $(MAIL_IDL_GENERATED_H)
-
-# IDL install
-
-idl_DATA = $(MAIL_IDL)
+module_LTLIBRARIES = \
+ libevolution-module-mail.la
+
+libevolution_module_mail_la_SOURCES = \
+ e-mail-shell-module.c \
+ e-mail-shell-module.h \
+ e-mail-shell-module-migrate.c \
+ e-mail-shell-module-migrate.h \
+ e-mail-shell-content.c \
+ e-mail-shell-content.h \
+ e-mail-shell-sidebar.c \
+ e-mail-shell-sidebar.h \
+ e-mail-shell-view.c \
+ e-mail-shell-view.h \
+ e-mail-shell-view-actions.c \
+ e-mail-shell-view-actions.h \
+ e-mail-shell-view-private.c \
+ e-mail-shell-view-private.h
+
+libevolution_module_mail_la_LIBADD = \
+ $(top_builddir)/shell/libeshell.la
# plugin mail api
-mailinclude_HEADERS = \
- $(MAIL_IDL_GENERATED_H) \
- em-composer-utils.h \
- em-config.h \
- em-event.h \
- em-folder-browser.h \
- em-folder-tree-model.h \
- em-folder-tree.h \
- em-folder-utils.h \
- em-folder-view.h \
- em-format-hook.h \
- em-format-html-display.h \
- em-format-html-print.h \
- em-format-html.h \
- em-format-quote.h \
- em-format.h \
- em-html-stream.h \
- em-icon-stream.h \
- em-inline-filter.h \
- em-junk-hook.h \
- em-menu.h \
- em-message-browser.h \
- em-popup.h \
- em-stripsig-filter.h \
- em-sync-stream.h \
- em-utils.h \
- mail-autofilter.h \
- mail-component.h \
- mail-config.h \
- mail-mt.h \
- mail-ops.h \
- mail-session.h \
- mail-tools.h \
- message-list.h \
- mail-vfolder.h
+#mailinclude_HEADERS = \
+# em-composer-utils.h \
+# em-config.h \
+# em-event.h \
+# em-folder-browser.h \
+# em-folder-tree-model.h \
+# em-folder-tree.h \
+# em-folder-utils.h \
+# em-folder-view.h \
+# em-format-hook.h \
+# em-format-html-display.h \
+# em-format-html-print.h \
+# em-format-html.h \
+# em-format-quote.h \
+# em-format.h \
+# em-html-stream.h \
+# em-icon-stream.h \
+# em-inline-filter.h \
+# em-junk-hook.h \
+# em-menu.h \
+# em-message-browser.h \
+# em-popup.h \
+# em-stripsig-filter.h \
+# em-sync-stream.h \
+# em-utils.h \
+# mail-autofilter.h \
+# mail-component.h \
+# mail-config.h \
+# mail-mt.h \
+# mail-ops.h \
+# mail-session.h \
+# mail-tools.h \
+# message-list.h \
+# mail-vfolder.h
# libevolution-mail
-libevolution_mail_la_SOURCES = \
- $(MAIL_IDL_GENERATED) \
- $(mailinclude_HEADERS) \
- e-searching-tokenizer.c \
- e-searching-tokenizer.h \
- em-account-editor.c \
- em-account-editor.h \
- em-account-prefs.c \
- em-account-prefs.h \
- em-composer-prefs.c \
- em-composer-prefs.h \
- em-composer-utils.c \
- em-config.c \
- em-event.c \
- em-filter-context.c \
- em-filter-context.h \
- em-filter-editor.c \
- em-filter-editor.h \
- em-filter-folder-element.c \
- em-filter-folder-element.h \
- em-filter-rule.c \
- em-filter-rule.h \
- em-filter-source-element.c \
- em-filter-source-element.h \
- em-folder-browser.c \
- em-folder-properties.c \
- em-folder-properties.h \
- em-folder-selection-button.c \
- em-folder-selection-button.h \
- em-folder-selection.c \
- em-folder-selection.h \
- em-folder-selector.c \
- em-folder-selector.h \
- em-folder-tree-model.c \
- em-folder-tree.c \
- em-folder-utils.c \
- em-folder-view.c \
- em-format-hook.c \
- em-format-html-display.c \
- em-format-html-print.c \
- em-format-html.c \
- em-format-quote.c \
- em-format.c \
- em-html-stream.c \
- em-icon-stream.c \
- em-inline-filter.c \
- em-junk-hook.c \
- em-mailer-prefs.c \
- em-mailer-prefs.h \
- em-menu.c \
- em-message-browser.c \
- em-migrate.c \
- em-migrate.h \
- em-network-prefs.c \
- em-network-prefs.h \
- em-popup.c \
- em-search-context.c \
- em-search-context.h \
- em-stripsig-filter.c \
- em-subscribe-editor.c \
- em-subscribe-editor.h \
- em-sync-stream.c \
- em-utils.c \
- em-vfolder-context.c \
- em-vfolder-context.h \
- em-vfolder-editor.c \
- em-vfolder-editor.h \
- em-vfolder-rule.c \
- em-vfolder-rule.h \
- mail-autofilter.c \
- mail-component-factory.c \
- mail-component.c \
- mail-config-factory.c \
- mail-config-factory.h \
- mail-config.c \
- mail-crypto.c \
- mail-crypto.h \
- mail-folder-cache.c \
- mail-folder-cache.h \
- mail-mt.c \
- mail-ops.c \
- mail-send-recv.c \
- mail-send-recv.h \
- mail-session.c \
- mail-signature-editor.c \
- mail-signature-editor.h \
- mail-tools.c \
- mail-types.h \
- mail-vfolder.c \
- message-list.c \
- message-tag-editor.c \
- message-tag-editor.h \
- message-tag-followup.c \
- message-tag-followup.h
+#libevolution_mail_la_SOURCES = \
+# $(mailinclude_HEADERS) \
+# e-searching-tokenizer.c \
+# e-searching-tokenizer.h \
+# em-account-editor.c \
+# em-account-editor.h \
+# em-account-prefs.c \
+# em-account-prefs.h \
+# em-composer-prefs.c \
+# em-composer-prefs.h \
+# em-composer-utils.c \
+# em-config.c \
+# em-event.c \
+# em-filter-context.c \
+# em-filter-context.h \
+# em-filter-editor.c \
+# em-filter-editor.h \
+# em-filter-folder-element.c \
+# em-filter-folder-element.h \
+# em-filter-rule.c \
+# em-filter-rule.h \
+# em-filter-source-element.c \
+# em-filter-source-element.h \
+# em-folder-browser.c \
+# em-folder-properties.c \
+# em-folder-properties.h \
+# em-folder-selection-button.c \
+# em-folder-selection-button.h \
+# em-folder-selection.c \
+# em-folder-selection.h \
+# em-folder-selector.c \
+# em-folder-selector.h \
+# em-folder-tree-model.c \
+# em-folder-tree.c \
+# em-folder-utils.c \
+# em-folder-view.c \
+# em-format-hook.c \
+# em-format-html-display.c \
+# em-format-html-print.c \
+# em-format-html.c \
+# em-format-quote.c \
+# em-format.c \
+# em-html-stream.c \
+# em-icon-stream.c \
+# em-inline-filter.c \
+# em-junk-hook.c \
+# em-mailer-prefs.c \
+# em-mailer-prefs.h \
+# em-menu.c \
+# em-message-browser.c \
+# em-migrate.c \
+# em-migrate.h \
+# em-network-prefs.c \
+# em-network-prefs.h \
+# em-popup.c \
+# em-search-context.c \
+# em-search-context.h \
+# em-stripsig-filter.c \
+# em-subscribe-editor.c \
+# em-subscribe-editor.h \
+# em-sync-stream.c \
+# em-utils.c \
+# em-vfolder-context.c \
+# em-vfolder-context.h \
+# em-vfolder-editor.c \
+# em-vfolder-editor.h \
+# em-vfolder-rule.c \
+# em-vfolder-rule.h \
+# mail-autofilter.c \
+# mail-component-factory.c \
+# mail-component.c \
+# mail-config-factory.c \
+# mail-config-factory.h \
+# mail-config.c \
+# mail-crypto.c \
+# mail-crypto.h \
+# mail-folder-cache.c \
+# mail-folder-cache.h \
+# mail-mt.c \
+# mail-ops.c \
+# mail-send-recv.c \
+# mail-send-recv.h \
+# mail-session.c \
+# mail-signature-editor.c \
+# mail-signature-editor.h \
+# mail-tools.c \
+# mail-types.h \
+# mail-vfolder.c \
+# message-list.c \
+# message-tag-editor.c \
+# message-tag-editor.h \
+# message-tag-followup.c \
+# message-tag-followup.h
if ENABLE_SMIME
SMIME_LIBS = \
@@ -191,30 +191,30 @@ SMIME_LIBS = \
$(top_builddir)/smime/gui/libevolution-smime.la
endif
-libevolution_mail_la_LIBADD = \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/shell/libeshell.la \
- $(top_builddir)/composer/libcomposer.la \
- $(top_builddir)/widgets/table/libetable.la \
- $(top_builddir)/widgets/text/libetext.la \
- $(top_builddir)/widgets/misc/libemiscwidgets.la \
- $(top_builddir)/widgets/misc/libefilterbar.la \
- $(top_builddir)/filter/libfilter.la \
- $(top_builddir)/widgets/menus/libmenus.la \
- $(top_builddir)/addressbook/util/libeabutil.la \
- $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
- $(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
- $(top_builddir)/mail/importers/libevolution-mail-importers.la \
- $(SMIME_LIBS) \
- $(EVOLUTION_MAIL_LIBS) \
- $(GTKHTML_LIBS) \
- $(REGEX_LIBS) \
- $(THREADS_LIBS)
-
-libevolution_mail_la_LDFLAGS = \
- -avoid-version -module $(NO_UNDEFINED)
-
-libevolution_mail_la_DEPENDENCIES = em-filter-i18n.h
+#libevolution_mail_la_LIBADD = \
+# $(top_builddir)/e-util/libeutil.la \
+# $(top_builddir)/shell/libeshell.la \
+# $(top_builddir)/composer/libcomposer.la \
+# $(top_builddir)/widgets/table/libetable.la \
+# $(top_builddir)/widgets/text/libetext.la \
+# $(top_builddir)/widgets/misc/libemiscwidgets.la \
+# $(top_builddir)/widgets/misc/libefilterbar.la \
+# $(top_builddir)/filter/libfilter.la \
+# $(top_builddir)/widgets/menus/libmenus.la \
+# $(top_builddir)/addressbook/util/libeabutil.la \
+# $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
+# $(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
+# $(top_builddir)/mail/importers/libevolution-mail-importers.la \
+# $(SMIME_LIBS) \
+# $(EVOLUTION_MAIL_LIBS) \
+# $(GTKHTML_LIBS) \
+# $(REGEX_LIBS) \
+# $(THREADS_LIBS)
+
+#libevolution_mail_la_LDFLAGS = \
+# -avoid-version -module $(NO_UNDEFINED)
+
+#libevolution_mail_la_DEPENDENCIES = em-filter-i18n.h
# .server files
@@ -246,7 +246,6 @@ etspec_DATA = message-list.etspec
EXTRA_DIST = \
ChangeLog.pre-1-4 \
README.async \
- $(MAIL_IDL) \
mail.error.xml \
$(glade_DATA) \
$(schema_in_files) \
@@ -302,7 +301,7 @@ endif
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-BUILT_SOURCES = $(MAIL_IDL_GENERATED) $(server_DATA) $(error_DATA)
+BUILT_SOURCES = $(server_DATA) $(error_DATA)
CLEANFILES = $(BUILT_SOURCES)