aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2002-11-18 19:36:50 +0800
committerMichael Zucci <zucchi@src.gnome.org>2002-11-18 19:36:50 +0800
commitfc6c2cd99b5b24a7957af9df611574ca30fa9bed (patch)
tree0b2c6acb25d4a1fa5047b0d6f82330994e41d404 /mail/Makefile.am
parentabda9814844d31daaf4c6355da9a886c69bda9be (diff)
downloadgsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar.gz
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar.bz2
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar.lz
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar.xz
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.tar.zst
gsoc2013-evolution-fc6c2cd99b5b24a7957af9df611574ca30fa9bed.zip
Added back libevolution-importer stuff. (SUBDIRS): Added back importers.
2002-11-18 Not Zed <NotZed@Ximian.com> * Makefile.am (evolution_mail_LDADD): Added back libevolution-importer stuff. (SUBDIRS): Added back importers. * importers/evolution-mbox-importer.c (load_file_fn): build the uri without deprecated funcs. (load_file_fn): dont free/alloc a camel_exception for no obvious purpose. (mbox_factory_fn): use weak_ref rather than destroy. (importer_destroy_cb): fix signature for weak ref notify. (mbox_factory_fn): add cid param. * importers/*.[ch]: ran fix script over everything. * importers/*.server.in.in: Added bonobo activation files. Moved evolution-mail to @LIBEXEC@ as below. * importers/Makefile.am: oaf->bonobo activation stuff. * importers/evolution-outlook-importer.c (outlook_factory_fn): Add component id to callback. svn path=/trunk/; revision=18822
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 645b952bbc..b1f5864174 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,4 +1,4 @@
-#SUBDIRS = importers
+SUBDIRS = importers
libexec_PROGRAMS = \
evolution-mail
@@ -138,22 +138,21 @@ evolution_mail_SOURCES = \
# mail-font-prefs.c \
# mail-font-prefs.h
-evolution_mail_LDADD = \
- $(top_builddir)/camel/libcamel.la \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/shell/libeshell.la \
- $(top_builddir)/composer/libcomposer.a \
- $(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/widgets/misc/libefilterbar.a \
+evolution_mail_LDADD = \
+ $(top_builddir)/shell/importer/libevolution-importer.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(top_builddir)/composer/libcomposer.a \
+ $(top_builddir)/widgets/misc/libemiscwidgets.a \
+ $(top_builddir)/widgets/misc/libefilterbar.a \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
- $(top_builddir)/libversit/libversit.a \
- $(top_builddir)/e-util/ename/libename.la \
- $(top_builddir)/filter/libfilter.la \
- $(top_builddir)/widgets/menus/libmenus.la \
+ $(top_builddir)/libversit/libversit.a \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/filter/libfilter.la \
+ $(top_builddir)/widgets/menus/libmenus.la \
$(EVOLUTION_MAIL_LIBS)
-# $(top_builddir)/shell/importer/libevolution-importer.la
-
evolution_mail_LDFLAGS = \
-export-dynamic