aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2009-03-02 11:14:42 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2009-03-02 11:14:42 +0800
commit85d0142d21286ce87cd5f6c3d1e2f71aa994151f (patch)
treeadf19534f082b2074b3c7e7faf0ef10aa5c51806 /mail/Makefile.am
parent08b1d0ae8e36ef20da800bf6358ca0cd9fb4e026 (diff)
downloadgsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar.gz
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar.bz2
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar.lz
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar.xz
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.tar.zst
gsoc2013-evolution-85d0142d21286ce87cd5f6c3d1e2f71aa994151f.zip
Move text searching UI into a new EMailSearchBar widget.
svn path=/branches/kill-bonobo/; revision=37351
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am138
1 files changed, 3 insertions, 135 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index cf7f71acea..ef5b769ce4 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -51,6 +51,8 @@ libevolution_module_mail_la_SOURCES = \
e-mail-reader.h \
e-mail-reader-utils.c \
e-mail-reader-utils.h \
+ e-mail-search-bar.c \
+ e-mail-search-bar.h \
e-mail-shell-module.c \
e-mail-shell-module.h \
e-mail-shell-module-migrate.c \
@@ -186,128 +188,6 @@ libevolution_module_mail_la_LIBADD = \
$(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
$(SMIME_LIBS)
-# plugin mail api
-#mailinclude_HEADERS = \
-# em-composer-utils.h \
-# em-config.h \
-# em-event.h \
-# em-folder-browser.h \
-# em-folder-tree-model.h \
-# em-folder-tree.h \
-# em-folder-utils.h \
-# em-folder-view.h \
-# em-format-hook.h \
-# em-format-html-display.h \
-# em-format-html-print.h \
-# em-format-html.h \
-# em-format-quote.h \
-# em-format.h \
-# em-html-stream.h \
-# em-icon-stream.h \
-# em-inline-filter.h \
-# em-junk-hook.h \
-# em-menu.h \
-# em-popup.h \
-# em-stripsig-filter.h \
-# em-sync-stream.h \
-# em-utils.h \
-# mail-autofilter.h \
-# mail-component.h \
-# mail-config.h \
-# mail-mt.h \
-# mail-ops.h \
-# mail-session.h \
-# mail-tools.h \
-# message-list.h \
-# mail-vfolder.h
-
-# libevolution-mail
-
-#libevolution_mail_la_SOURCES = \
-# $(mailinclude_HEADERS) \
-# e-searching-tokenizer.c \
-# e-searching-tokenizer.h \
-# em-account-editor.c \
-# em-account-editor.h \
-# em-account-prefs.c \
-# em-account-prefs.h \
-# em-composer-prefs.c \
-# em-composer-prefs.h \
-# em-composer-utils.c \
-# em-config.c \
-# em-event.c \
-# em-filter-context.c \
-# em-filter-context.h \
-# em-filter-editor.c \
-# em-filter-editor.h \
-# em-filter-folder-element.c \
-# em-filter-folder-element.h \
-# em-filter-rule.c \
-# em-filter-rule.h \
-# em-filter-source-element.c \
-# em-filter-source-element.h \
-# em-folder-browser.c \
-# em-folder-properties.c \
-# em-folder-properties.h \
-# em-folder-selection-button.c \
-# em-folder-selection-button.h \
-# em-folder-selection.c \
-# em-folder-selection.h \
-# em-folder-selector.c \
-# em-folder-selector.h \
-# em-folder-tree-model.c \
-# em-folder-tree.c \
-# em-folder-utils.c \
-# em-folder-view.c \
-# em-format-hook.c \
-# em-format-html-display.c \
-# em-format-html-print.c \
-# em-format-html.c \
-# em-format-quote.c \
-# em-format.c \
-# em-html-stream.c \
-# em-icon-stream.c \
-# em-inline-filter.c \
-# em-junk-hook.c \
-# em-menu.c \
-# em-migrate.c \
-# em-migrate.h \
-# em-popup.c \
-# em-search-context.c \
-# em-search-context.h \
-# em-stripsig-filter.c \
-# em-subscribe-editor.c \
-# em-subscribe-editor.h \
-# em-sync-stream.c \
-# em-utils.c \
-# em-vfolder-context.c \
-# em-vfolder-context.h \
-# em-vfolder-editor.c \
-# em-vfolder-editor.h \
-# em-vfolder-rule.c \
-# em-vfolder-rule.h \
-# mail-autofilter.c \
-# mail-component-factory.c \
-# mail-component.c \
-# mail-config.c \
-# mail-folder-cache.c \
-# mail-folder-cache.h \
-# mail-mt.c \
-# mail-ops.c \
-# mail-send-recv.c \
-# mail-send-recv.h \
-# mail-session.c \
-# mail-signature-editor.c \
-# mail-signature-editor.h \
-# mail-tools.c \
-# mail-types.h \
-# mail-vfolder.c \
-# message-list.c \
-# message-tag-editor.c \
-# message-tag-editor.h \
-# message-tag-followup.c \
-# message-tag-followup.h
-
if ENABLE_SMIME
SMIME_LIBS = \
$(top_builddir)/smime/lib/libessmime.la \
@@ -319,10 +199,6 @@ endif
# $(top_builddir)/filter/libfilter.la \
# $(top_builddir)/widgets/menus/libmenus.la \
# $(top_builddir)/addressbook/util/libeabutil.la \
-# $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
-# $(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
-# $(top_builddir)/mail/importers/libevolution-mail-importers.la \
-# $(SMIME_LIBS) \
# $(EVOLUTION_MAIL_LIBS) \
# $(GTKHTML_LIBS) \
# $(REGEX_LIBS) \
@@ -333,14 +209,6 @@ endif
#libevolution_mail_la_DEPENDENCIES = em-filter-i18n.h
-# .server files
-
-server_in_files = GNOME_Evolution_Mail.server.in.in
-server_DATA = $(server_in_files:.server.in.in=.server)
-
-@EVO_SERVER_RULE@
-@INTLTOOL_SERVER_RULE@
-
# Misc data to install
filterdir = $(privdatadir)
filter_DATA = filtertypes.xml vfoldertypes.xml searchtypes.xml
@@ -418,7 +286,7 @@ endif
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-BUILT_SOURCES = $(server_DATA) $(error_DATA)
+BUILT_SOURCES = $(error_DATA)
CLEANFILES = $(BUILT_SOURCES)