aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-08-02 14:13:26 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-08-02 14:13:26 +0800
commit77316d782f31a8c321dbe8ccb9220c0a85f7fc47 (patch)
treefc852533e634144cb8139a998c53dd08715236a3 /mail/Makefile.am
parentef025c689be33a54883b5e8b77e58916d1c8002d (diff)
downloadgsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar.gz
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar.bz2
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar.lz
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar.xz
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.tar.zst
gsoc2013-evolution-77316d782f31a8c321dbe8ccb9220c0a85f7fc47.zip
Add EVOLUTION_BUTTONSDIR to get to some different icons.
2001-08-02 Not Zed <NotZed@Ximian.com> * Makefile.am (INCLUDES): Add EVOLUTION_BUTTONSDIR to get to some different icons. * mail-ops.c (mail_sync_folder): Queue the folder sync operation, rather than running it in parallel. * mail-send-recv.c: applies anna's patch for prettier send-recv dialogue. (parse_url): Renamed to format_url, fixed callers. (format_url): Use camel_url_free instead of g_free, also handle case where we have no host (use path instead). (build_dialogue): Cleaned up some whitespace. (build_dialogue): Create the label directly with the right text, dont set any text in the progress bar, and save the label into the info struct for later updating. (struct _send_info): Added 'status' the label with the status string. (operation_status_timeout): (receive_done): (receive_cancel): Set the status label, not the progress format text. (hide_send_info): NULL out status too. (mail_receive_uri): Init status. (free_folder_info): Initiate a folder sync here, so we can ... (free_send_data): ... Remove the awful hack of iterating through bonobo controls to sync all open folders. (free_send_data): Initiate a sync of the inbox too. (build_dialogue): Remove set_alignment on the icon, its not a gtkmisc object. svn path=/trunk/; revision=11566
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index b29861960c..156ceb55b8 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -22,6 +22,7 @@ INCLUDES = \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
@@ -139,6 +140,7 @@ etspecdir = $(datadir)/evolution/etspec/
etspec_DATA = message-list.etspec
iconsdir = $(datadir)/images/evolution
+buttonsdir = $(datadir)/images/evolution/buttons
$(EVOLUTION_MAIL_CORBA_GENERATED): Mail.idl
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl -I `$(GNOME_CONFIG) --cflags idl` \