aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2003-01-09 20:17:19 +0800
committerMichael Zucci <zucchi@src.gnome.org>2003-01-09 20:17:19 +0800
commit6e9cb1e2bf29610e0d111572e72244b11542cc8d (patch)
tree21db40dbfab1d71cd0316457ed3679f362bef96f /mail/Makefile.am
parent45d0c39700d2d6ee12f45c17778d69f3119ba078 (diff)
downloadgsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar.gz
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar.bz2
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar.lz
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar.xz
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.tar.zst
gsoc2013-evolution-6e9cb1e2bf29610e0d111572e72244b11542cc8d.zip
Added druidpagestart1 to the pages list. (construct): Change the limits on
2003-01-09 Not Zed <NotZed@Ximian.com> * mail-config-druid.c: Added druidpagestart1 to the pages list. (construct): Change the limits on the page initialisation, and widget_show_all on the page rather than the content. * GNOME_Evolution_Mail.server.in.in: Make Mail a shlib component. * folder-info.c (evolution_folder_info_factory_init): Removed. (evolution_folder_info_factory_fn): renamed to evolution_folder_info_new(). * mail-config-druid.c (evolution_mail_config_wizard_factory_fn): Renamed to evolution_mail_config_wizard_new(). (evolution_mail_config_wizard_init): Removed. * mail-config-factory.c (mail_config_register_factory): Remove. (config_control_factory_cb): make this public. * Makefile.am: setup evolution-mail as a shared library. * component-factory.c (make_factory): implement the bonobo-plugin factory for shlib operation. Also, preliminary work to setup mailer-specific (factory): Implement the factory which starts various components. * mail-config.c (xml_get_prop): g_free->xmlFree (account_to_xml): copy xml memory to glib memory when adding the 0 on the end of the string. (accounts_save): Use slightly different logic with appending to the tail of the list, we can't use the &node trick with gslists. (accounts_changed): Same here. svn path=/trunk/; revision=19362
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 4c89094492..dbdb944a0c 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,7 +1,7 @@
SUBDIRS = importers
-libexec_PROGRAMS = \
- evolution-mail
+#libexec_PROGRAMS = \
+# evolution-mail
# evolution-mail-upgrade
importerdir = $(privlibdir)/evolution-mail-importers
@@ -34,6 +34,9 @@ INCLUDES = \
-DGTK_DISABLE_DEPRECATED \
-DG_LOG_DOMAIN=\"evolution-mail\"
+componentdir = $(COMPONENT_DIR)
+component_LTLIBRARIES = libevolution-mail.la
+
EVOLUTION_MAIL_CORBA_GENERATED = \
Mailer.h \
Mailer-common.c \
@@ -53,7 +56,7 @@ $(IDL_GENERATED): $(SPELL_IDL)
Spell-impl.o: Spell.h
-evolution_mail_SOURCES = \
+libevolution_mail_la_SOURCES = \
$(EVOLUTION_MAIL_CORBA_GENERATED) \
$(IDL_GENERATED) \
component-factory.c \
@@ -140,7 +143,7 @@ evolution_mail_SOURCES = \
# mail-font-prefs.c \
# mail-font-prefs.h
-evolution_mail_LDADD = \
+libevolution_mail_la_LIBADD = \
$(top_builddir)/shell/importer/libevolution-importer.la \
$(top_builddir)/camel/libcamel.la \
$(top_builddir)/e-util/libeutil.la \
@@ -155,7 +158,7 @@ evolution_mail_LDADD = \
$(top_builddir)/widgets/menus/libmenus.la \
$(EVOLUTION_MAIL_LIBS)
-evolution_mail_LDFLAGS = \
+libevolution_mail_la_LDFLAGS = \
-export-dynamic
#evolution_mail_upgrade_SOURCES = upgrade-mailer.c
@@ -169,7 +172,7 @@ server_in_files = GNOME_Evolution_Mail.server.in.in
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
gladedir = $(datadir)/evolution/glade