aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-07 00:31:54 +0800
committerDan Winship <danw@src.gnome.org>2003-02-07 00:31:54 +0800
commit69b0509f10188551fa1f5d0e9999002a27372827 (patch)
treee4e3fdb0c6644903b76a38cf1e5b61de3f0ed972 /mail/Makefile.am
parent50ff525b79aaa97ab627d5dfd4c9e65fe013ecce (diff)
downloadgsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar.gz
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar.bz2
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar.lz
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar.xz
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.tar.zst
gsoc2013-evolution-69b0509f10188551fa1f5d0e9999002a27372827.zip
Remove *dir defs that are in configure.in now (INCLUDES): clean up using
* Makefile.am: Remove *dir defs that are in configure.in now (INCLUDES): clean up using new *dir variables (libevolution_mail_la_LDFLAGS): remove -export-dynamic, add -module * importers/Makefile.am (INCLUDES): change EVOLUTION_DATADIR to EVOLUTION_PRIVDATADIR * importers/netscape-importer.c (netscape_import_filters): use EVOLUTION_PRIVDATADIR svn path=/trunk/; revision=19805
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am63
1 files changed, 29 insertions, 34 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index fe2713070e..89ff12ecfb 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -6,34 +6,34 @@ SUBDIRS = importers
importerdir = $(privlibdir)/evolution-mail-importers
-INCLUDES = \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/camel \
- -I$(top_srcdir) \
- -I$(top_srcdir)/composer \
- -I$(top_builddir)/composer \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- -I$(top_srcdir)/shell/importer \
- -I$(top_builddir)/shell/importer \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- $(EVOLUTION_MAIL_CFLAGS) \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_IMAGES=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
- -DEVOLUTION_GALVIEWSDIR=\"$(datadir)/evolution-$(BASE_VERSION)/views\" \
- -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
- -DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
- -DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
- -DG_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
+INCLUDES = \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/composer \
+ -I$(top_builddir)/composer \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir)/shell/importer \
+ -I$(top_builddir)/shell/importer \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
+ -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
+ -DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
-DG_LOG_DOMAIN=\"evolution-mail\"
component_LTLIBRARIES = libevolution-mail.la
@@ -161,7 +161,7 @@ libevolution_mail_la_LIBADD = \
$(EVOLUTION_MAIL_LIBS)
libevolution_mail_la_LDFLAGS = \
- -export-dynamic -avoid-version
+ -avoid-version -module
#evolution_mail_upgrade_SOURCES = upgrade-mailer.c
#evolution_mail_upgrade_LDADD = \
@@ -171,23 +171,18 @@ libevolution_mail_la_LDFLAGS = \
server_in_files = GNOME_Evolution_Mail.server.in.in
-serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = mail-config.glade local-config.glade subscribe-dialog.glade message-tags.glade
-etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
etspec_DATA = mail-accounts.etspec message-list.etspec subscribe-dialog.etspec
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_DATA = evolution-mail.schemas
-buttonsdir = $(datadir)/evolution-$(BASE_VERSION)/images/buttons
-
idl_DATA = Mailer.idl
$(EVOLUTION_MAIL_CORBA_GENERATED): Mailer.idl