aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2008-04-05 23:26:26 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-04-05 23:26:26 +0800
commit52ba74cef488e616e07b2ae8f5e93df8a9e31081 (patch)
tree629dd2edcd1f27ccb9b6661e4a95a85ea0656413 /mail/Makefile.am
parent20fca64c5a4d78d11a61b5689d97cf164caea08f (diff)
downloadgsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar.gz
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar.bz2
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar.lz
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar.xz
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.tar.zst
gsoc2013-evolution-52ba74cef488e616e07b2ae8f5e93df8a9e31081.zip
** Fixes part of bug #526152, plus some tangential code cleanup.
2008-04-05 Matthew Barnes <mbarnes@redhat.com> ** Fixes part of bug #526152, plus some tangential code cleanup. * mail/Makefile.am: Remove all the IDL crud for GnomeSpell. * mail/em-composer-prefs.c: * mail/evolution-mail.schemas.in: * mail/mail-config.c: Define our own GConf keys for active spell checking languages and the underline color for misspelled words, instead of relying on GnomeSpell's GConf keys. The new keys are: /apps/evolution/mail/composer/spell_color (string) /apps/evolution/mail/composer/spell_languages (list of strings) * mail/em-composer-prefs.c: * mail/em-composer-prefs.h: Cleanup the logic a bit to improve readability. * mail/mail-config.c: Cleanup the GConf notification logic: - We don't need the notification IDs for GConf keys we're watching. - Minimize the repetition of GConf keys to reduce the risk of typos. - Reduce the number of notification callback functions. * mail/Spell.idl: Remove this file; we don't use GnomeSpell anymore. * composer/e-msg-composer.c: * composer/e-composer-private.h: Initialize a new composer's spell checking language menu via our new "spell_languages" GConf key. * tools/killev.c (main): No need to continue killing the GnomeSpell Bonobo server. svn path=/trunk/; revision=35322
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am22
1 files changed, 1 insertions, 21 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index ba0ba784db..3cbd23c825 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -33,24 +33,6 @@ INCLUDES = \
component_LTLIBRARIES = libevolution-mail.la
-# Code generation for Spell.idl
-
-SPELL_IDL = Spell.idl
-
-SPELL_IDL_GENERATED_H = \
- Spell.h
-SPELL_IDL_GENERATED_C = \
- Spell-common.c \
- Spell-skels.c \
- Spell-stubs.c
-SPELL_IDL_GENERATED = $(SPELL_IDL_GENERATED_C) $(SPELL_IDL_GENERATED_H)
-
-$(SPELL_IDL_GENERATED_H): $(SPELL_IDL)
- $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $(srcdir)/Spell.idl
-$(SPELL_IDL_GENERATED_C): $(SPELL_IDL_GENERATED_H)
-
-Spell-impl.o: Spell.h
-
# Mail.idl
MAIL_IDL = Evolution-Mail.idl
MAIL_IDL_GENERATED_H = \
@@ -110,7 +92,6 @@ mailinclude_HEADERS = \
# libevolution-mail
libevolution_mail_la_SOURCES = \
- $(SPELL_IDL_GENERATED) \
$(MAIL_IDL_GENERATED) \
$(MARSHAL_GENERATED) \
$(mailinclude_HEADERS) \
@@ -271,7 +252,6 @@ EXTRA_DIST = \
ChangeLog.pre-1-4 \
README.async \
em-marshal.list \
- $(SPELL_IDL) \
$(MAIL_IDL) \
mail.error.xml \
$(glade_DATA) \
@@ -328,7 +308,7 @@ endif
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-BUILT_SOURCES = $(SPELL_IDL_GENERATED) $(MAIL_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(error_DATA)
+BUILT_SOURCES = $(MAIL_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(error_DATA)
CLEANFILES = $(BUILT_SOURCES)