aboutsummaryrefslogtreecommitdiffstats
path: root/macros/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-08-03 06:26:45 +0800
committerDan Winship <danw@src.gnome.org>2000-08-03 06:26:45 +0800
commita0281d1b1860f650ba2293e422cbc9ec7ee2012b (patch)
treebbeff35e0957b12fd53be52f87c7ddc1c7377108 /macros/Makefile.am
parent83cbc862e6981bd06b406a0ae01e50d15a3502e7 (diff)
downloadgsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar.gz
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar.bz2
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar.lz
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar.xz
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.tar.zst
gsoc2013-evolution-a0281d1b1860f650ba2293e422cbc9ec7ee2012b.zip
Fix "cvs rm -rf" lossage.
svn path=/trunk/; revision=4480
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
new file mode 100644
index 0000000000..ed4b5fa19e
--- /dev/null
+++ b/macros/Makefile.am
@@ -0,0 +1,42 @@
+## Please update this variable if any new macros are created
+
+MACROS= \
+ aclocal-include.m4 \
+ compiler-flags.m4 \
+ curses.m4 \
+ gnome-bonobo-check.m4 \
+ gnome-fileutils.m4 \
+ gnome-ghttp-check.m4 \
+ gnome-gnorba-check.m4 \
+ gnome-guile-checks.m4 \
+ gnome-libgtop-check.m4 \
+ gnome-objc-checks.m4 \
+ gnome-orbit-check.m4 \
+ gnome-print-check.m4 \
+ gnome-pthread-check.m4 \
+ gnome-support.m4 \
+ gnome-undelfs.m4 \
+ gnome-vfs.m4 \
+ gnome-x-checks.m4 \
+ gnome-xml-check.m4 \
+ gnome.m4 \
+ gperf-check.m4 \
+ linger.m4 \
+ need-declaration.m4
+
+EXTRA_DIST=$(MACROS) gnome-common.m4 autogen.sh
+MAINTAINERCLEANFILES=macros.dep
+
+@MAINT@macros.dep: Makefile.am
+@MAINT@ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=macros/%)' > $@
+
+if INSIDE_GNOME_COMMON
+gnome_aclocaldir = $(datadir)/aclocal/gnome-macros
+
+gnome-macros.dep: Makefile.am
+ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=$(gnome_aclocaldir)/%)' > $@
+
+gnome_aclocal_DATA = $(MACROS) gnome-macros.dep gnome-common.m4 \
+ autogen.sh
+
+endif